Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов

Публикация № 1150965

Администрирование - Администрирование данных 1С - Обработка документов

заявка открытие ЗУП ЗКГУ подбор 19 символов лицевой счет XML

Расширение добавляет кнопку "Подбор" в документ "Заявка на открытие лицевых счетов". И отключает проверку на 19 символов в латинском Фамилии, Имени при выгрузке.

По кнопке "Подбор" открывается форма списка сотрудников работающих на дату документа.

Если сотрудник работает по основному месту и внутреннему совместительству, то в документ попадет одно физическое лицо.

К сожалению при подборе на подсвечиваются уже выбранные сотрудники, т.к. форма подбора отражает справочник сотрудники, а в документе справочник физические лица.

В расширении следует отключить безопасный режим.

Тестировалась на: Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.9.229).

 

Пример кода из расширения (кнопка подбор):

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеПодборСотрудниковПосле(Команда)
	
	//ПерсонифицированныйУчетКлиент.ПодобратьФизическихЛиц(Элементы.ЛицевыеСчета, Объект.Организация, АдресСпискаПодобранныхСотрудников());
	
	ПараметрыОткрытия = Новый Структура;
	
	Отборы = Новый Структура("ПоказыватьДоговорниковГПХ", Ложь);
	ПараметрыОткрытия.Вставить("Отбор", Отборы);
			
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихВПериодеПоПараметрамОткрытияФормыСписка(
		Элементы.ЛицевыеСчета,
		Объект.Организация,
		,
		НачалоДня(Объект.Дата),
		КонецДня(Объект.Дата),
		,
		АдресСпискаПодобранныхСотрудников(),
		ПараметрыОткрытия);

КонецПроцедуры

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеЛицевыеСчетаОбработкаВыбораПосле(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	 ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение);

КонецПроцедуры

&НаСервере
Процедура ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение)
	
	Валюта = Справочники.Валюты.НайтиПоКоду("643");
	
	СписокФизическихЛиц = Новый ТаблицаЗначений();
	СписокФизическихЛиц.Колонки.Добавить("ФизическоеЛицо", Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица"));
	
	Для каждого Строка Из ВыбранноеЗначение Цикл
		
		НоваяСтрока = СписокФизическихЛиц.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
	КонецЦикла;
	
	СписокФизическихЛиц.Свернуть("ФизическоеЛицо");
	
	Для каждого Строка Из СписокФизическихЛиц Цикл
		
		НоваяСтрока = Объект.Сотрудники.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
		ДокументОбъект = РеквизитФормыВЗначение("Объект");
		ДокументОбъект.ЗаполнитьСтрокуТабличнойЧастиДаннымиДляОткрытияЛицевыхСчетов(ДокументОбъект.Дата, НоваяСтрока.НомерСтроки);
		ЗначениеВРеквизитФормы(ДокументОбъект, "Объект")
		
	КонецЦикла;
	
	Для каждого Строка Из Объект.Сотрудники Цикл
		
		//Строка.ЯвляетсяЗарплатнойКартой = Истина;
		Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
		Строка.ВалютаВклада = Валюта;
		
	КонецЦикла;
		
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов:
.cfe 49,40Kb
08.11.19
16
.cfe 49,40Kb 16 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. DJDUH 17 08.11.19 15:29 Сейчас в теме
Запрос в цикле, ай-я-я-й-й!!!

Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Справочники.Валюты.НайтиПоКоду("643");
		
КонецЦикла;
Показать



Валюта643 = Справочники.Валюты.НайтиПоКоду("643");
Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Валюта643 ;
		
КонецЦикла;
Показать
2. GeterX 744 08.11.19 17:04 Сейчас в теме
3. chesnokov-a-v 99 17.12.19 14:35 Сейчас в теме
Установил расширение, но кнопка "Подбор" не появилась. ЗУП 3.1.11.133
4. GeterX 744 17.12.19 14:40 Сейчас в теме
(3) в описании написано: "В расширении следует отключить безопасный режим."
5. chesnokov-a-v 99 17.12.19 20:06 Сейчас в теме
(4) конечно это было сделано. попробую разобраться в проблеме чуть позже.
6. GeterX 744 17.12.19 20:24 Сейчас в теме
(5) попробуйте поискать в меню Ещё табличной части документа.
7. chesnokov-a-v 99 18.12.19 11:28 Сейчас в теме
(6) Появилась. Удалил расширение и добавил заново, с несколькими перезапусками (магия).
8. Amras 43 20.12.19 09:41 Сейчас в теме
Так попроще будет, а уж добавить команду (ПодобратьСотрудников) на форму, думаю, труда не составит. И при всем при этом используем исключительно типовые механизмы (протестировано на ЗУП КОРП 3.1.10.223), кроме получения ФизическогоЛица.

&НаКлиенте
Процедура ПодобратьСотрудников(Команда)
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихНаДатуПоПараметрамОткрытияФормыС­писка(
		Элементы.ЛицевыеСчета,,,,,АдресСпискаПодобранныхСотрудников());
КонецПроцедуры
	
// Возвращает адрес во временном хранилище массива уже подобранных сотрудников.
//
&НаСервере
Функция АдресСпискаПодобранныхСотрудников()
	СписокСотрудников = Объект.Сотрудники.Выгрузить(,"ФизическоеЛицо").ВыгрузитьКолонку("ФизическоеЛицо");
	
	Возврат ПоместитьВоВременноеХранилище(СписокСотрудников, УникальныйИдентификатор);
КонецФункции

&НаКлиенте
Процедура ЛицевыеСчетаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Для каждого ВыбранныйСотрудник Из ВыбранноеЗначение Цикл
		
		мФизЛицо = МГ_ПолучитьФизЛицо(ВыбранныйСотрудник);
		
		Если Объект.Сотрудники.НайтиСтроки(Новый Структура("ФизическоеЛицо", мФизЛицо)).Количество() = 0 Тогда
			НовыйСотрудник = Объект.Сотрудники.Добавить();
			НовыйСотрудник.ФизическоеЛицо = мФизЛицо;
			
			ЗаполнитьСтрокуНаСервере(НовыйСотрудник.НомерСтроки);
			
			Модифицированность = Истина;
		КонецЕсли;
	КонецЦикла; 
КонецПроцедуры

&НаСервере
Функция МГ_ПолучитьФизЛицо(Сотрудник)
	Возврат Сотрудник.ФизическоеЛицо;
КонецФункции
Показать
Evgeniy_stv; +1 Ответить
9. mart1120 26.05.20 18:09 Сейчас в теме
Скачала для ЗУП 3.1. Не работает.
Ошибка: Не удалось добавить расширение. ....
....
Ошибка применения расширения конфигурации: Значение контролируемого свойства Режим совместимости у объекта не совпадает со значением расширяемой конфигурации.


Можно поправить?
12. GeterX 744 26.05.20 20:25 Сейчас в теме
(9) расширение поправлю.
а сейчас чтобы повторно не скачивать, установите расширение через конфигуратор, и в свойствах расширения снимите галку с совместимости.
Прикрепленные файлы:
10. mart1120 26.05.20 18:33 Сейчас в теме
Платформа 8.3.15.1830
конфигурация ЗУП 3.1.13.188
11. mart1120 26.05.20 19:39 Сейчас в теме
На старых релизах работает. Проверяла.
13. mart1120 26.05.20 21:24 Сейчас в теме
Спасибо! Все получилось!
Оставьте свое сообщение

См. также

daСклонение: склонение ФИО, должностей, чисел, прилагательных, существительных на языке 1С + ТестЦентр Промо

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция предназначена для склонения выражений, которые часто требуется при формировании печатных форм договоров и прочих печатных форм. Функция склоняет по падежам ФИО, должности, числительные, валюты, единицы измерения, предметы. Также функция склоняет глаголы и прилагательные по числам и родам и существительные по числам. Имеется режим определения рода переданного выражения. Поддержка форматной строки для вывода результата. Функция не использует внешние библиотеки и веб-сервисы, написана на чистом языке 1С, и поэтому легко встраивается в любую конфигурацию или внешнюю обработку. Правила склонения оформлены в виде таблицы и могут быть легко изменены при необходимости.

1 стартмани

14.02.2015    99090    96    daMaster    88    

Сравнение реального дохода со средним доходом из API.HH.RU

Зарплата Управленческие v8 v8::СПР ЗУП3.x УУ Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с HH.RU используя HH REST API. Ключевые функции: получение списка вакансий по должностям (Ключ для работы не нужен); расчет среднего дохода; Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.13.1513) Зарплата и управление персоналом, редакция 3.1 (3.1.11.68) совместно с API.HH.RU.

1 стартмани

11.11.2019    3646    4    solaru    2    

Конфигурация для рекламного агентства

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) v8 Реклама, PR и маркетинг УУ Абонемент ($m)

Данная конфигурация выполнена для решения тестового задания: Цель задания: 1) Понять, на каком из клиентов сколько мы заработали;  2) Понять, по какому виду СМИ сколько мы заработали;  3) Проследить по каждой услуге: у кого за сколько купили и кому за сколько продали, с возможностью перейти в соответствующий документ. Реализовано с помощью: 1. Справочники - контрагенты, номенклатура 2. Документы - Поступление услуг, реализация услуг 3. Отчеты - отчет по контрагентам, номенклатуре и движений.

1 стартмани

21.05.2019    3927    0    solaru    0    

Загрузка номенклатуры в УТ 10.3 из Excel файла с генерацией штрихкодов

Загрузка и выгрузка в Excel Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 Россия Абонемент ($m)

Обработка позволяет генерировать новые номенклатурные позиции на основе данных из файла Excel с последующей генерацией штрихкодов (ШК). Может быть полезна при больших поступлениях товаров на склад, где ручное создание и присваивание штрихкода  (ШК) может занимать много времени.

1 стартмани

24.03.2017    7529    6    solaru    0    

Под капотом управляемых форм

Практика программирования v8 1cv8.cf Бесплатно (free)

Управляемые формы уже давно и плотно вошли в жизнь 1С-разработчика. Однако, судя по недавним публикациям на Инфостарте, многие до сих пор мало знакомы с ними. Предлагаю разобраться с тем, что же это такое.

26.08.2013    260513    0    Evil Beaver    266    

[NotaBene] Универсальный отчет по таблице значений

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Данная обработка решает часто встречающуюся задачу вывода в "красивом" виде таблицы значений (полученной, например, из запроса). Поддерживается произвольное группирование данных, отключение/включение группировок, в т.ч и создание "шахматок" (типа "продажи понедельно"). Обработка может использоваться как и в отладочных целях (для нормального просмотра ТЗ), так и в составе вполне рабочих отчетов. По крайней мере, я неоднократно клиентам данную обработку ставил вместо того, чтобы каждый раз писать замороченные выводы данных. И клиенты довольны, и мне - проще...

2 стартмани

07.05.2007    27919    1    CheBurator    61