Форма расчета по страховым взносам за 1 кв. 2020 г. для ЗУП 2.5

Публикация № 1224939

Разработка - Печать - Регламентированная отчетность

РСВ ЗУП

Регламентированный отчет для расчета по страховым взносам из редакции КОРП (форма от 18.09.2019 №ММВ-7-11/470), адаптированный для ЗУП 2.5.130.2

Алгоритмы заполнения и выгрузки перенесены без изменений, но пришлось слегка модифицировать оригинальный запрос, т.к. в версии 2.5.130.2 отсутствует реквизит ЛьготныйТерриториальныйТариф регистра накопления СтраховыеВзносыСведенияОДоходах и некоторые значения перечисления ТарифыСтраховыхВзносов, поэтому будьте внимательны при расчете для льготных территорий.

Открывается через Файл - Открыть. Тестировалось на ЗУП 2.5.130.2

18.04.2020. Починил проверку контрольных соотношений и добавил расшифровку показателей

21.04.2020. Решение проблемы выгрузки данных по доп. тарифам

В схеме выгрузки у узла РасчСВ_ОПС428 отсутствует имя раздела, поэтому при заполнении он не попадает в условие и пропускается. Довольно странно, т.к. в других конфигурациях (БП 3, ЗУП 3.1) схема аналогичная. Временно отредактировал схему, отчет обновил.

23.04.2020. Исправлены мелкие ошибки: печать бланка без штрихкода, просмотр отчетов прошлых периодов

Скачать файлы

Наименование Файл Версия Размер
Расчет по страховым взносам за 1 кв. 2020 г. для ЗУП 2.5
.erf 2,14Mb
16.04.20
80
.erf 2,14Mb 80 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. SGordon1 16.04.20 10:44 Сейчас в теме
А что там с 3 разделом, в корпе по моему закомментарено все или есть отдельная внешняя форма?
3. tikhmyanov 11 16.04.20 17:58 Сейчас в теме
5. tikhmyanov 11 17.04.20 07:06 Сейчас в теме
(1) Посмотрел в отладчике — старые процедуры заполнения раздела закомментированы, теперь данные заполняются раньше, прямо в процедуре ЗаполнитьАвто
38. малышка-глупышка 23.04.20 13:17 Сейчас в теме
(1) на упп 1.3.137 тоже закомментировано и не заполняет, не подскажете как у вас решилось?
40. SGordon1 23.04.20 19:12 Сейчас в теме
(38) Как то раньше стало заполнять, что то у меня вылезло с последними релизами ЗУП. Но пока забросили это все..
2. Karlosss 16.04.20 13:41 Сейчас в теме
Есть купившие? А то хочу купить, а отзывов нет. Вдруг что не работает
50. hellf 23 07.05.20 13:47 Сейчас в теме
нашла ошибку при формировании корректировочного отчета
Исправлять в отчете РегламентированныйОтчетРасчетПоСтраховымВзносам Форма ЗаполнениеРегламентированнойОтчетности (либо в скачанном внешнем, если не добавляли в конфигурацию его)

строка9721. Неправильно написали перечисление:

 //++Было: ДоходыВзносов.Колонки.Добавить("П00321М113001", Новый ОписаниеТипов("Строка,ПеречислениеСсылка.КатегорииЗастрахованныхЛицДляПФР", , Новый КвалификаторыСтроки(4)));
//++нужно:
        ДоходыВзносов.Колонки.Добавить("П00321М113001", Новый ОписаниеТипов("Строка,ПеречислениеСсылка.КатегорииЗастрахованныхЛицПФР", , Новый КвалификаторыСтроки(4)));
tikhmyanov; +1 Ответить
51. tikhmyanov 11 07.05.20 16:31 Сейчас в теме
(50) Спасибо, исправил у себя
6. snogl 17.04.20 17:19 Сейчас в теме
(2)Работает. Сегодня для своих бухов скачал, на ЗП базовая версия.
tikhmyanov; +1 Ответить
53. tricolor 21 14.05.20 17:03 Сейчас в теме
(6) А не лучше было перейти на ЗУП 3?
7. a.rezyhin 22 18.04.20 17:42 Сейчас в теме
Не подскажете а для Зарплата и кадры бюджетного учреждения, редакция 1.0 подойдет?
8. a.rezyhin 22 18.04.20 18:37 Сейчас в теме
Тестирую на ЗИК БУ вроде как заполняет. Из видимых проблем пока только то, что не работает расшифровка. Метод объекта не обнаружен (ВывестиОтчетРасшифровку)
11. tikhmyanov 11 18.04.20 19:56 Сейчас в теме
(8) Сейчас попробую починить
12. tikhmyanov 11 18.04.20 23:14 Сейчас в теме
(8) Обновил, попробуйте, если что — мой телеграм в профиле
9. a.rezyhin 22 18.04.20 19:18 Сейчас в теме
и уточните, пожалуйста, что за "ЛьготныйТерриториальныйТариф" ? Я проверил в ЗУП 2.5 КОРП актуального релиза, там тоже нет такого измерения.
10. tikhmyanov 11 18.04.20 19:55 Сейчас в теме
(9) Дезинформировал, ЛьготныйТерриториальныйТариф — это реквизит регистра
13. dsv59@mail.ru 19.04.20 02:10 Сейчас в теме
Нет выгрузки по дополнительному тарифу. Подразделы 1.3.1 и 1.3.2. А у нас есть такие разделы. Кстати в сам отчет все стает. Но не печатает и не вызружает
15. tikhmyanov 11 20.04.20 09:06 Сейчас в теме
(13) Могу я посмотреть базу? Напишите мне (телеграм в профиле), как будет время
16. hellf 23 20.04.20 15:21 Сейчас в теме
(15)присоединяюсь к вопросу. Если раньше обнаружите- напишите, пожалуйста, как решили проблему. если я разберусь раньше- добавлю сюда.
23. tikhmyanov 11 20.04.20 19:51 Сейчас в теме
(16) Не могу воспроизвести проблему на тестовой, можете показать любую запись регистра накопления СтраховыеВзносыИсчисленные? И желательно узел РасчетСВ из файла выгрузки. Телеграм: tikhmyanov
26. hellf 23 20.04.20 22:24 Сейчас в теме
(23)проще всего привесить доп тариф на кого-то, пересчитать зп и начисление стр взносов.
27. tikhmyanov 11 21.04.20 08:40 Сейчас в теме
(26) Поправил схему, протестируйте, пожалуйста
28. hellf 23 21.04.20 08:47 Сейчас в теме
29. hellf 23 21.04.20 09:01 Сейчас в теме
(27)простите, туплю с утра. в схему раздел только добавить пока для теста?
31. tikhmyanov 11 21.04.20 09:11 Сейчас в теме
(29) Да, решение рабочее, но меня смущает, что в других конфигурациях схема такая же. Отредактированную схему прикрепил
Прикрепленные файлы:
СхемаВыгрузки502.mxl
dada2; NadinPr; hellf; +3 Ответить
32. hellf 23 21.04.20 09:20 Сейчас в теме
(27)Все отлично! выводится в файл
tikhmyanov; +1 Ответить
14. dsv59@mail.ru 19.04.20 02:47 Сейчас в теме
Для того, чтобы эти разделы РАСШИФРОВЫВАЛИСЬ надо доработать СформироватьОтчетРасшифровку

Процедура СформироватьОтчетРасшифровку(Параметры, ДокументРезультат) Экспорт
	
	ИмяПоля = Лев(Параметры.ИДИменПоказателей[0], 13);
	ДатаНачалаНП = НачалоГода(Параметры.ДатаНачалаПериода);
	ДатаКонцаНП  = КонецДня(Параметры.ДатаОкончанияПериода);
	
	// Получаем данные расшифровки.
	ВнешниеНаборыДанных = Новый Структура;
	ВнешниеНаборыДанных.Вставить(Параметры.ИмяСКД); // Имя внешнего набора данных совпадает с ключем варианта.
		
	ОбособленноеПодразделение = Справочники.ПодразделенияОрганизаций.ПустаяСсылка();
	Если Параметры.Свойство("ОбособленноеПодразделение") Тогда
		ОбособленноеПодразделение = Параметры.ОбособленноеПодразделение;
	КонецЕсли;
	Если Параметры.ИмяРасчета = "РасчетПоказателей_РСВ_2020" Тогда
		ЗаполнениеРегламентированнойОтчетности.РасчетПоказателей_РСВ_2020(Параметры.ДатаНачалаПериода, Параметры.ДатаОкончанияПериода, Параметры.ДатаПодписи, Параметры.Организация, ОбособленноеПодразделение, ВнешниеНаборыДанных, Истина);
	Иначе
		ЗаполнениеРегламентированнойОтчетности.РасчетПоказателей_РСВ_2017Кв1(Параметры.ДатаНачалаПериода, Параметры.ДатаОкончанияПериода, Параметры.ДатаПодписи, Параметры.Организация, ОбособленноеПодразделение, ВнешниеНаборыДанных, Истина);
	КонецЕсли;
	
	// Удалим строки с нулевым значением показателя.
	Данные = ВнешниеНаборыДанных[Параметры.ИмяСКД];
	ВсегоСтрок = Данные.Количество();
	Для Сч = 1 По ВсегоСтрок Цикл
		СтрокаДанных = Данные[ВсегоСтрок - Сч];
		Если Не ЗначениеЗаполнено(СтрокаДанных[ИмяПоля]) Тогда
			Данные.Удалить(СтрокаДанных)
		КонецЕсли;
	КонецЦикла;
	
	// Подготовим табличку для проверки с учетом отборов.
	ДанныеДляПроверки = Неопределено;
	Если Параметры.Свойство("ЗначениеТекущегоПоказателя") Тогда
		ДанныеДляПроверки = Данные.Скопировать();
	КонецЕсли;
	
	// Настраиваем СКД и выводим отчет.
	СхемаКомпоновкиДанных = ПолучитьМакет(Параметры.ИмяСКД);
	
	КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
	КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.ВариантыНастроек[Параметры.ИмяСКД].Настройки);
	НастройкиКомпоновки = КомпоновщикНастроек.Настройки;
	
	УстанавливатьШиринуКолонкиОтборов = Ложь;
	ТиповыеОтчеты.ДобавитьВыбранноеПоле(КомпоновщикНастроек, ИмяПоля, ?(Параметры.Свойство("ЗаголовокПоля") И ЗначениеЗаполнено(Параметры.ЗаголовокПоля), Параметры.ЗаголовокПоля, ""));
	Если Параметры.Свойство("Раздел1Прил1КодТарифа") И ЗначениеЗаполнено(Параметры.Раздел1Прил1КодТарифа) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "КодТарифа", Параметры.Раздел1Прил1КодТарифа, ДанныеДляПроверки)
	КонецЕсли;
	Если Параметры.Свойство("Раздел1Прил1Подр1_3_1ПризнакОснования") И ЗначениеЗаполнено(Параметры.Раздел1Прил1Подр1_3_1ПризнакОснования) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "П11131М100101", Параметры.Раздел1Прил1Подр1_3_1ПризнакОснования, ДанныеДляПроверки)
	КонецЕсли;
	Если Параметры.Свойство("Раздел1Прил1Подр1_3_2КодОснования") И ЗначениеЗаполнено(Параметры.Раздел1Прил1Подр1_3_2КодОснования) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "П11132М100101", Параметры.Раздел1Прил1Подр1_3_2КодОснования, ДанныеДляПроверки)
	КонецЕсли;

ЭТО НАДО ЗАКОМЕНТИРОВАТЬ


	//Если Параметры.Свойство("Раздел1Прил1Подр1_3_2КодКлассаУсловий") И ЗначениеЗаполнено(Параметры.Раздел1Прил1Подр1_3_2КодКлассаУсловий) Тогда
	//	ДобавитьОтборПоПараметру(НастройкиКомпоновки, "П11132М100301", Параметры.Раздел1Прил1Подр1_3_2КодКлассаУсловий, ДанныеДляПроверки)
	//КонецЕсли;




	Если Параметры.Свойство("Раздел1Прил1Подр1_4КодОснования") И ЗначениеЗаполнено(Параметры.Раздел1Прил1Подр1_4КодОснования) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "П01114М100101", Параметры.Раздел1Прил1Подр1_4КодОснования, ДанныеДляПроверки)
	КонецЕсли;
 	Если Параметры.Свойство("Раздел1Прил1_1КодОснования") И ЗначениеЗаполнено(Параметры.Раздел1Прил1_1КодОснования) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "П00111М100101", Параметры.Раздел1Прил1_1КодОснования, ДанныеДляПроверки)
	КонецЕсли;
	Если Параметры.Свойство("Раздел1Прил2КодТарифа") И ЗначениеЗаполнено(Параметры.Раздел1Прил2КодТарифа) Тогда
		ДобавитьОтборПоПараметру(НастройкиКомпоновки, "КодТарифа", Параметры.Раздел1Прил2КодТарифа, ДанныеДляПроверки)
	КонецЕсли;
	
	Если ДанныеДляПроверки <> Неопределено Тогда
		Если Параметры.ЗначениеТекущегоПоказателя <> ДанныеДляПроверки.Итог(ИмяПоля) Тогда
			СтрокаОтбора = 6;
		КонецЕсли;
		ЗаполнениеРегламентированнойОтчетности.ВывестиПредупреждениеОРасхожденииПоказателяСРасшифровкой(Параметры.ЗначениеТекущегоПоказателя, ДанныеДляПроверки.Итог(ИмяПоля), ДокументРезультат);
	КонецЕсли;
	ДанныеДляПроверки = Неопределено;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиКомпоновки);
		
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ВнешниеНаборыДанных);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки, Истина);
	
	Если УстанавливатьШиринуКолонкиОтборов Тогда
		ДокументРезультат.Область(СтрокаОтбора, 2, СтрокаОтбора, 2).ШиринаКолонки = 65;
	КонецЕсли;
	
КонецПроцедуры
Показать
41. Lukich66 82 28.04.20 13:35 Сейчас в теме
(14) Добрый день,Вы просто закомментировали "П11132М10301", да расшифровка заработала,но не корректно( при наличии нескольких разделов 3.2)
24. dsv59@mail.ru 20.04.20 21:29 Сейчас в теме
Я подготовил файл. посмотри.
Прикрепленные файлы:
Пример.xlsx
25. dsv59@mail.ru 20.04.20 21:32 Сейчас в теме
Ребята. Я не блогер. Я не понимаю, что такое (телеграм в профиле) . Сбросьте на мой возраст. У меня внучке больше 20 лет
33. Swetlana 13 21.04.20 18:11 Сейчас в теме
(25) Телеграм: tikhmyanov
телеграмм для связи, имя автора tikhmyanov. Внучка подскажет
34. NadinPr 1 22.04.20 08:13 Сейчас в теме
ЗУП КОРП редакция 2.5 (2.5.149.4)

У нас тоже не печатаются подразделы 1.3.1 и 1.3.2

Скачала вашу форму - у вас печатаются эти разделы.

Подскажите где поправить в конфигурации, чтоб печаталась из регламентированных отчетов?



Все разобралась, спасибо!
tikhmyanov; +1 Ответить
35. Zyevkl 23.04.20 11:25 Сейчас в теме
(34)
ЗУП КОРП редакция 2.5 (2.5.149.4)

У нас тоже не печатаются подразделы 1.3.1 и 1.3.2


Как решили проблему?
36. Zyevkl 23.04.20 11:37 Сейчас в теме
37. tikhmyanov 11 23.04.20 11:37 Сейчас в теме
(35) Нужно внести изменения в схему (РегламентированныйОтчетРасчетПоСтраховымВзносам - Макеты - СхемаВыгрузки502) — добавить пропущенное имя раздела, я отметил расположение в описании. Готовая схема есть в (31)
39. Zyevkl 23.04.20 13:26 Сейчас в теме
(37)понял, спасибо, интересно как работает в 3.1
42. aleksmen 28.04.20 18:48 Сейчас в теме
Скажите, штрих код тот что слева вверху, как сделать чтобы отображался ?
В старом отчете есть..
43. tikhmyanov 11 28.04.20 19:13 Сейчас в теме
(42) 1620 2016? Сейчас проверил — отображается на предпросмотре обычной формы и формы с двумерным ШК. Напишите мне в телеграм, попробую помочь
Прикрепленные файлы:
44. dada2 29.04.20 20:59 Сейчас в теме
У меня работает. Все супер.
45. Evgen54 5 06.05.20 19:54 Сейчас в теме
А на 2.5.124.3 будет работать?
46. tikhmyanov 11 07.05.20 06:19 Сейчас в теме
(45) Нет, только что проверил на базовой, сильно отличаются общие модули, 2.5.129.3 — минимальная, на которой получилось заполнить
47. hellf 23 07.05.20 10:32 Сейчас в теме
что-то у нас при формировании корректировки ошибка вылетает при заполнении.
а первичный нормально формировался

проверьте у себя, нормально проходит? и с чем это может быть связано-то?
Прикрепленные файлы:
48. tikhmyanov 11 07.05.20 11:15 Сейчас в теме
(47) Можете дать доступ? У меня на нескольких базах без ошибок
49. hellf 23 07.05.20 11:26 Сейчас в теме
именно корректировка без ошибок?
первичный формируется
52. Evgen54 5 13.05.20 04:45 Сейчас в теме
А можно как-то без старт мани скачать обработку или на почту выслать (evgen2454*gmail.com). Пожалуйста. Сильно надо а то на счету тока 0.89.
Оставьте свое сообщение

См. также

daСклонение: склонение ФИО, должностей, чисел, прилагательных, существительных на языке 1С + ТестЦентр Промо

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция предназначена для склонения выражений, которые часто требуется при формировании печатных форм договоров и прочих печатных форм. Функция склоняет по падежам ФИО, должности, числительные, валюты, единицы измерения, предметы. Также функция склоняет глаголы и прилагательные по числам и родам и существительные по числам. Имеется режим определения рода переданного выражения. Поддержка форматной строки для вывода результата. Функция не использует внешние библиотеки и веб-сервисы, написана на чистом языке 1С, и поэтому легко встраивается в любую конфигурацию или внешнюю обработку. Правила склонения оформлены в виде таблицы и могут быть легко изменены при необходимости.

1 стартмани

14.02.2015    99311    96    daMaster    88    

Сравнение реального дохода со средним доходом из API.HH.RU

Зарплата Управленческие v8 v8::СПР ЗУП3.x УУ Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с HH.RU используя HH REST API. Ключевые функции: получение списка вакансий по должностям (Ключ для работы не нужен); расчет среднего дохода; Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.13.1513) Зарплата и управление персоналом, редакция 3.1 (3.1.11.68) совместно с API.HH.RU.

1 стартмани

11.11.2019    3679    4    solaru    2    

Конфигурация для рекламного агентства

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) v8 Реклама, PR и маркетинг УУ Абонемент ($m)

Данная конфигурация выполнена для решения тестового задания: Цель задания: 1) Понять, на каком из клиентов сколько мы заработали;  2) Понять, по какому виду СМИ сколько мы заработали;  3) Проследить по каждой услуге: у кого за сколько купили и кому за сколько продали, с возможностью перейти в соответствующий документ. Реализовано с помощью: 1. Справочники - контрагенты, номенклатура 2. Документы - Поступление услуг, реализация услуг 3. Отчеты - отчет по контрагентам, номенклатуре и движений.

1 стартмани

21.05.2019    3983    0    solaru    0    

Загрузка номенклатуры в УТ 10.3 из Excel файла с генерацией штрихкодов

Загрузка и выгрузка в Excel Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 Россия Абонемент ($m)

Обработка позволяет генерировать новые номенклатурные позиции на основе данных из файла Excel с последующей генерацией штрихкодов (ШК). Может быть полезна при больших поступлениях товаров на склад, где ручное создание и присваивание штрихкода  (ШК) может занимать много времени.

1 стартмани

24.03.2017    7557    6    solaru    0    

Под капотом управляемых форм

Практика программирования v8 1cv8.cf Бесплатно (free)

Управляемые формы уже давно и плотно вошли в жизнь 1С-разработчика. Однако, судя по недавним публикациям на Инфостарте, многие до сих пор мало знакомы с ними. Предлагаю разобраться с тем, что же это такое.

26.08.2013    260928    0    Evil Beaver    266    

[NotaBene] Универсальный отчет по таблице значений

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Данная обработка решает часто встречающуюся задачу вывода в "красивом" виде таблицы значений (полученной, например, из запроса). Поддерживается произвольное группирование данных, отключение/включение группировок, в т.ч и создание "шахматок" (типа "продажи понедельно"). Обработка может использоваться как и в отладочных целях (для нормального просмотра ТЗ), так и в составе вполне рабочих отчетов. По крайней мере, я неоднократно клиентам данную обработку ставил вместо того, чтобы каждый раз писать замороченные выводы данных. И клиенты довольны, и мне - проще...

2 стартмани

07.05.2007    27966    1    CheBurator    61