Заполнение табличных частей документов одного вида из табличных частей списка документов другого вида (альтернатива ввода на основании)

Публикация № 1311336

Администрирование - Администрирование данных 1С - Обработка документов

Обработка заполнения табличных частей документа из других документов

Обработка табличных частей помогает бухгалтерам заполнять одни документы на основании других, причем можно делать на основании списка выбранных документов один документ. Заменяет и дополняет ввод на основании, использует механизм заполнения табличных частей.

Обработки предназначены для заполнения табличных частей документов Требование- накладная, Реализация услуг по переработке, Передача товаров для УПП 1.3 Протестировано на УПП 1.3 (1.3.147.1) Платформа 1С 8.3.17.1549

Обработка состоит в общем-то из одной процедуры модуля объекта

Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
	Если Объект.Проведен Тогда
		Предупреждение("Заполнение возможно только в непроведенном документе");
		Возврат;
	КонецЕсли;		
	Если Объект.Товары.Количество() > 0 Тогда
		Ответ = Вопрос("В документе уже присутствуют строки!
			|При заполнении табличная часть будет очищена.
			|Продолжить?", РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Нет);
		Если Не Ответ = КодВозвратаДиалога.Да Тогда
			Возврат;
		КонецЕсли;
	КонецЕсли;
	Объект.Товары.Очистить();
	
	ФормаОбработки = ЭтотОбъект.ПолучитьФорму();
	ФормаОбработки.ОткрытьМодально();
	
	Если СписокПоступлений.Количество() > 0 ТОгда
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ПоступлениеТоваровТовары.Номенклатура,
		|	ПоступлениеТоваровТовары.ЕдиницаИзмеренияМест,
		|	ПоступлениеТоваровТовары.КоличествоМест,
		|	ПоступлениеТоваровТовары.Ссылка.Сделка КАК Заказ,
		|	ПоступлениеТоваровТовары.ЕдиницаИзмерения,
		|	ПоступлениеТоваровТовары.Количество,
		|	ПоступлениеТоваровТовары.Цена,
		|	ПоступлениеТоваровТовары.Сумма,
		|	ПоступлениеТоваровТовары.Коэффициент,
		|	ПоступлениеТоваровТовары.ХарактеристикаНоменклатуры,
		|	ПоступлениеТоваровТовары.СерияНоменклатуры,
		|	ПоступлениеТоваровТовары.СчетУчетаБУ,
		|	ПоступлениеТоваровТовары.СчетУчетаНУ,
		|	ПоступлениеТоваровТовары.Ссылка.СкладОрдер КАК Склад		
		|ИЗ
		|	Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровТовары
		|ГДЕ
		|	ПоступлениеТоваровТовары.Ссылка В(&СписокПоступлений)
		|ИТОГИ ПО
		|	ОБЩИЕ";

		Запрос.УстановитьПараметр("СписокПоступлений", СписокПоступлений);

		РезультатЗапроса = Запрос.Выполнить();
		ТабЗапроса = РезультатЗапроса.Выгрузить();
		ТабЗапроса.Свернуть("Номенклатура,ЕдиницаИзмеренияМест,ЕдиницаИзмерения,Цена,ХарактеристикаНоменклатуры,СерияНоменклатуры,Коэффициент,СчетУчетаБУ,СчетУчетаНУ","Количество,КоличествоМест,Сумма");
		ТабЗапроса.Колонки.Добавить("Качество");
		МассивУдаления = Новый Массив;
		Для Каждого Строка Из ТабЗапроса Цикл
			Если НЕ ЗначениеЗаполнено(Строка.Номенклатура) Тогда 
				МассивУдаления.Добавить(Строка);
			Иначе
				Строка.Качество = Справочники.Качество.Новый;
			КонецЕсли;
		КонецЦикла;
		Для каждого Стр Из МассивУдаления Цикл
			ТабЗапроса.Удалить(Стр);
		КонецЦикла;
		Объект.Товары.Загрузить(ТабЗапроса);
		Для Каждого СтрокаП ИЗ Объект.Товары Цикл
			ОбработкаТабличныхЧастей.ПриИзмененииНоменклатурыТабЧасти(СтрокаП, Объект);
			ОбработкаТабличныхЧастей.ЗаполнитьЕдиницуЦенуПродажиТабЧасти(СтрокаП, Объект, Константы.ВалютаРегламентированногоУчета.Получить());
			ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаП, Объект);
			// Рассчитываем реквизиты табличной части.
			Объект.ЗаполнитьСчетаУчетаВСтрокеТабЧастиРегл(СтрокаП, "Товары", Объект.ОтражатьВБухгалтерскомУчете, Объект.ОтражатьВНалоговомУчете);
		КонецЦИкла;
	КонецЕсли;
КонецПроцедуры

Главная фишка в том, что при открытии обработки вам будет предложено из списка документов выбрать нужные. И вы можете на основании нескольких авансовых отчетов сделать один документ Требование накладная.

Подключаются обработки с помощью стандартного механизма УПП. Под интерфейсом Полный. Сервис - Дополнительные внешние отчеты и обработки - Обработки заполнения табличных частей. После загрузки обработки в базу УПП появляются новые строчки в меню Заполнить табличных частей указанных документов, как указано на рисунках анонса

Скачать файлы

Наименование Файл Версия Размер
Обработка заполнения табличной части Требование накладная из табличных частей списка перемещений товаров

.epf 8,98Kb
16.10.20
0
.epf 8,98Kb Скачать
Заполнение Требования накладной из списка авансовых отчетов

.epf 9,25Kb
16.10.20
0
.epf 9,25Kb Скачать
Заполнение Реализации услуг по переработке из списка Отчетов производства за смену

.epf 9,49Kb
16.10.20
0
.epf 9,49Kb Скачать
Заполнение документа Передача товаров из списка документов Отчет производства за смену

.epf 9,21Kb
16.10.20
0
.epf 9,21Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

daСклонение: склонение ФИО, должностей, чисел, прилагательных, существительных на языке 1С + ТестЦентр Промо

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция предназначена для склонения выражений, которые часто требуется при формировании печатных форм договоров и прочих печатных форм. Функция склоняет по падежам ФИО, должности, числительные, валюты, единицы измерения, предметы. Также функция склоняет глаголы и прилагательные по числам и родам и существительные по числам. Имеется режим определения рода переданного выражения. Поддержка форматной строки для вывода результата. Функция не использует внешние библиотеки и веб-сервисы, написана на чистом языке 1С, и поэтому легко встраивается в любую конфигурацию или внешнюю обработку. Правила склонения оформлены в виде таблицы и могут быть легко изменены при необходимости.

1 стартмани

14.02.2015    104409    98    daMaster    90    

Сравнение реального дохода со средним доходом из API.HH.RU

Зарплата Управленческие v8 v8::СПР ЗУП3.x УУ Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с HH.RU используя HH REST API. Ключевые функции: получение списка вакансий по должностям (Ключ для работы не нужен); расчет среднего дохода; Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.13.1513) Зарплата и управление персоналом, редакция 3.1 (3.1.11.68) совместно с API.HH.RU.

1 стартмани

11.11.2019    4381    6    solaru    2    

Конфигурация для рекламного агентства

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) v8 Реклама, PR и маркетинг УУ Абонемент ($m)

Данная конфигурация выполнена для решения тестового задания: Цель задания: 1) Понять, на каком из клиентов сколько мы заработали;  2) Понять, по какому виду СМИ сколько мы заработали;  3) Проследить по каждой услуге: у кого за сколько купили и кому за сколько продали, с возможностью перейти в соответствующий документ. Реализовано с помощью: 1. Справочники - контрагенты, номенклатура 2. Документы - Поступление услуг, реализация услуг 3. Отчеты - отчет по контрагентам, номенклатуре и движений.

1 стартмани

21.05.2019    5319    0    solaru    0    

Загрузка номенклатуры в УТ 10.3 из Excel файла с генерацией штрихкодов

Загрузка и выгрузка в Excel Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 Россия Абонемент ($m)

Обработка позволяет генерировать новые номенклатурные позиции на основе данных из файла Excel с последующей генерацией штрихкодов (ШК). Может быть полезна при больших поступлениях товаров на склад, где ручное создание и присваивание штрихкода  (ШК) может занимать много времени.

1 стартмани

24.03.2017    8233    7    solaru    0    

Под капотом управляемых форм

Практика программирования v8 1cv8.cf Бесплатно (free)

Управляемые формы уже давно и плотно вошли в жизнь 1С-разработчика. Однако, судя по недавним публикациям на Инфостарте, многие до сих пор мало знакомы с ними. Предлагаю разобраться с тем, что же это такое.

26.08.2013    269621    Evil Beaver    271    

[NotaBene] Универсальный отчет по таблице значений

Практика программирования v7.7 1cv7.md Россия Абонемент ($m)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Данная обработка решает часто встречающуюся задачу вывода в "красивом" виде таблицы значений (полученной, например, из запроса). Поддерживается произвольное группирование данных, отключение/включение группировок, в т.ч и создание "шахматок" (типа "продажи понедельно"). Обработка может использоваться как и в отладочных целях (для нормального просмотра ТЗ), так и в составе вполне рабочих отчетов. По крайней мере, я неоднократно клиентам данную обработку ставил вместо того, чтобы каждый раз писать замороченные выводы данных. И клиенты довольны, и мне - проще...

2 стартмани

07.05.2007    29503    3    CheBurator    63