Особенности обмена данными с использованием "ручной" регистрации

Публикация № 169237

Разработка - Обмен данными 1С - Распределенная БД (УРИБ, УРБД)

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

Причиной создания данной статьи послужил разбор непонятной ситуации, когда работал себе обмен более года и все было отлично, но, как обычно, в один прекрасный момент стали вылазить непонятные ситуации, о которых я попытаюсь подробно описать.

В детали обмена я вникать не буду, так как это никому не нужно, но в саму сущность придется все же посветить, например, куда идет обмен, сколько узлов там задействовано, какой принцип регистрации обмена (так как в этом вся важность), ну, и самое интересное - почему обмен перестал работать.

Смысл заложен таков, что есть определенное количество баз, которые обмениваются в одну "Базу отчетности". В этой базе никто ничего не вводит, она только аккумулирует все базы в единое целое для управленческой отчетности.

Опишу прикрепленный рисунок "BaseExchange". В нем отражено, что в базу для отчетности по какой-то причине перестали доходить движения по документам (сами же документы доходили).

 

Также видно, что при обмене используется два разных плана обмена, а это значит, что когда данные получает база "Магазин Самара" от базы "Магазин Владимир", то на узлах регистрации плана обмена "TraidePoint" должна произойти регистрация обмена по выделенным обработчикам событий: "ПередЗаписьюДокументаДляTradePointОбмен", "ПриЗаписиРегистрыНакопленияДляTradePointОбмен" (есть еще обработчики справочников и регистров сведений). 

На этих обработчиках прописан соответствующий код с условиями, например обмен должен идти только по организации "ООО Добро". 

При отладке кода стало ясно, что когда пытался зарегистрироваться набор записей регистра накоплений, условие по Регистратор.Организация не срабатывало лишь потому, что документ загружался позже. То есть он в файле загрузке был, но очередность его была после наборов записей и таким образом условие не срабатывало.

Здесь есть два выхода из ситуации:

  1. это попытаться использовать отбор по измерениям где есть Организация. Таким образом условие накладывается на текущий набор и на его измерение (данный метод меня не устроил, так как не все регистры которые мне нужны при обмене имеют измерение "Организация" или ссылку на этот справочник).
  2. при выгрузке обмена прописать правила очередности, а именно:
Функция ВыгрузитьИзмененияДанныхДляУзла(УзелОбмена, КолвоЭлементовВТранзакцииНаВыгрузкуДанных, ЗаписьXML) Экспорт

    ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();
    ЗаписьСообщения.НачатьЗапись(ЗаписьXML,УзелОбмена);

    ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(ЗаписьСообщения.Получатель,ЗаписьСообщения.НомерСообщения);

    //1. Справочники
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("Справочники",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;

        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;

    //2.Документы
    ВыборкаИзменений.Сбросить();
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("Документы",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;

        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;

    //3.Регистры
    ВыборкаИзменений.Сбросить();
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("РегистрыСведений",МетаданныеОбъекта)
            и НЕ ОбщегоНазначения.ПринадлежностьКлассуМетаданных("РегистрыНакопления",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;


        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;


    ЗаписьСообщения.ЗакончитьЗапись();
    ЗаписьXML.Закрыть();

    Возврат Истина;

КонецФункции
Вот собственно и все! А, кстати, чуть не забыл, а как оно работало раньше, Вы спросите?! Каким образом в базу отчетности движения попадали, и никто ничего не трогал в коде по обмену и данные вдруг перестали доходить.

Здесь все просто, как оказалось человек, который ежедневно перепроводил всю пачку документов ушел в отпуск. А когда документы он перепроводил - то срабатывала подписка, и если документ в базе уже был, то, естественно, условие уже на Регистратор.Организация успешно срабатывало. 

Будьте внимательны и бдительны при разработке такого рода обмена. 

Диме - отдельная благодарность за нахождение и устранение ошибочной ситуации. 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. anton.fly7 149 14.01.13 18:22 Сейчас в теме
я движения перегружаю только по тем регистрам, по которым нет обмена регистраторами
например накопления по дисконтным картам
остальные движения создаются проведениям регистраторов в базе получателе после обмена
2. kapustinag 15.01.13 00:40 Сейчас в теме
(1) anton.fly7, не для любого обмена подойдет вариант с проведением документов после обмена в базе-приемнике. Так как в общем случае не все документы охвачены обменом, то проведение документа вообще может завершиться ошибкой в базе-приемнике.
3. logarifm 1072 15.01.13 19:34 Сейчас в теме
И также не забываем, что проведение документов это доп. затраты на ресурсоемкость. И да - ошибок при проведении может быть масса, которых устранять некому, а по отчетам будет видно основные проблемы которые будут исправлятся в базах соответствующего назначения.
4. via64 16.01.13 13:55 Сейчас в теме
Можно, в правилах обмена, установить, у ПВД документа, более высокий приоритет, чем у ПВД регистра. Тогда, документы, будут выгружаться раньше. Но, я бы, вообще отключил ПВД регистра и вызывал бы ПКО регистра, по ссылке, из ПКО документа.
5. logarifm 1072 17.01.13 18:27 Сейчас в теме
Читаем вниамтельно САБЖ: "ручной" регистрации
Оставьте свое сообщение

См. также

daСклонение: склонение ФИО, должностей, чисел, прилагательных, существительных на языке 1С + ТестЦентр Промо

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция предназначена для склонения выражений, которые часто требуется при формировании печатных форм договоров и прочих печатных форм. Функция склоняет по падежам ФИО, должности, числительные, валюты, единицы измерения, предметы. Также функция склоняет глаголы и прилагательные по числам и родам и существительные по числам. Имеется режим определения рода переданного выражения. Поддержка форматной строки для вывода результата. Функция не использует внешние библиотеки и веб-сервисы, написана на чистом языке 1С, и поэтому легко встраивается в любую конфигурацию или внешнюю обработку. Правила склонения оформлены в виде таблицы и могут быть легко изменены при необходимости.

1 стартмани

14.02.2015    99102    96    daMaster    88    

Сравнение реального дохода со средним доходом из API.HH.RU

Зарплата Управленческие v8 v8::СПР ЗУП3.x УУ Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с HH.RU используя HH REST API. Ключевые функции: получение списка вакансий по должностям (Ключ для работы не нужен); расчет среднего дохода; Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.13.1513) Зарплата и управление персоналом, редакция 3.1 (3.1.11.68) совместно с API.HH.RU.

1 стартмани

11.11.2019    3647    4    solaru    2    

Конфигурация для рекламного агентства

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Производство готовой продукции (работ, услуг) v8 Реклама, PR и маркетинг УУ Абонемент ($m)

Данная конфигурация выполнена для решения тестового задания: Цель задания: 1) Понять, на каком из клиентов сколько мы заработали;  2) Понять, по какому виду СМИ сколько мы заработали;  3) Проследить по каждой услуге: у кого за сколько купили и кому за сколько продали, с возможностью перейти в соответствующий документ. Реализовано с помощью: 1. Справочники - контрагенты, номенклатура 2. Документы - Поступление услуг, реализация услуг 3. Отчеты - отчет по контрагентам, номенклатуре и движений.

1 стартмани

21.05.2019    3928    0    solaru    0    

Загрузка номенклатуры в УТ 10.3 из Excel файла с генерацией штрихкодов

Загрузка и выгрузка в Excel Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 Россия Абонемент ($m)

Обработка позволяет генерировать новые номенклатурные позиции на основе данных из файла Excel с последующей генерацией штрихкодов (ШК). Может быть полезна при больших поступлениях товаров на склад, где ручное создание и присваивание штрихкода  (ШК) может занимать много времени.

1 стартмани

24.03.2017    7531    6    solaru    0    

Под капотом управляемых форм

Практика программирования v8 1cv8.cf Бесплатно (free)

Управляемые формы уже давно и плотно вошли в жизнь 1С-разработчика. Однако, судя по недавним публикациям на Инфостарте, многие до сих пор мало знакомы с ними. Предлагаю разобраться с тем, что же это такое.

26.08.2013    260522    0    Evil Beaver    266    

[NotaBene] Универсальный отчет по таблице значений

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Данная обработка решает часто встречающуюся задачу вывода в "красивом" виде таблицы значений (полученной, например, из запроса). Поддерживается произвольное группирование данных, отключение/включение группировок, в т.ч и создание "шахматок" (типа "продажи понедельно"). Обработка может использоваться как и в отладочных целях (для нормального просмотра ТЗ), так и в составе вполне рабочих отчетов. По крайней мере, я неоднократно клиентам данную обработку ставил вместо того, чтобы каждый раз писать замороченные выводы данных. И клиенты довольны, и мне - проще...

2 стартмани

07.05.2007    27923    1    CheBurator    61