Push сообщения с использованием Firebase cloud message

Программирование - Мобильные приложения

Используем новую технологию FCM, отправляем пуши на устройства на базе Android, инициируем вызов сервера клиентом с самого сервера.

Всех приветствую.

Сегодня расскажу о том, как можно быстро и легко отправить произвольное push сообщение с сервера на мобильное устройство на базе Android (на iOS нет возможности попробовать, на Windows Phone этот метод работать не будет, по крайней мере пока). 

Чтобы пример был осмысленным, внесем немного ясности. Допустим есть некая конфигурация, которая крутится на неком ПК - назовем это Сервер. Есть необходимость в том, чтобы при наступлении какого-либо события на Сервере была инициирована, например, синхронизация с одним или несколькими телефоном/ТСД (далее просто мобильное устройство или МУ).  На самом деле можно придумать любой другой пример, но суть в том,  что инициатива какого-либо действия будет именно со стороны Сервера а не МУ.  Сигналом к действию для МУ и будет выступать push сообщение.

Вот такая вот небольшая задача, которую надо решить.

Нам потребуется:

  1.  Платформа 8.3.6 и выше
  2.  Мобильная платформа 8.3.6 и выше
  3.  Аккаунт Google 
  4. Около 20 мин свободного времени )

О том, как развернуть мобильную платформу для разработчика на своем устройстве писать не буду, информации много (я лично слушал бесплатный курс многоуважаемого DitriX).

Ну, приступим. Откроем конфигурацию Сервера и создадим в ней общую форму, из которой будем отправлять пуши клиенту. На форме создадим одну команду, которая и будет отправлять сообщение. Теперь разберемся, каким объектом на уровне платформы представлено push сообщение.  СП подскажет нам, что это ДоставляемоеУведомление. Его инициализация довольно простая, объект доступен везде, кроме Вэб-клиента, что нас вполне устраивает. Поместим следующий код в обработчик нажатия команды общей формы. Контекст выполнения в данном случае не важен. Сразу оговорюсь, что дальше по тексту не будет каких либо проверок на корректность данных, это и так все понятно.

    Уведомление                    = Новый ДоставляемоеУведомление;
    Уведомление.Заголовок		   = "Необходимо выполнить синхронизацию";
	Уведомление.Текст			   = "Новые задания ожидают загрузки на устройство.";
	Уведомление.Данные 			   = "ВыполнитьСинхронизацию";
	Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;

Если бы мы хотели использовать локальные уведомления мобильной платформы на самом МУ, то такой инициализации было бы вполне достаточно, но у нас задача прислать пуш от сервера. Поэтому придется разобраться с еще одним свойством объекта ДоставляемоеУведомление, а именно Получатели. Это массив, то есть при желании можно отправить сообщение сразу нескольким МУ (например, если документ уже был выгружен на МУ1, а затем менеджер решил, что документ должен быть на МУ2). Тип данных элементов этого массива ИдентификаторПодписчикаДоставляемыхУведомлений, и опять же смотрим СП и видим, что о нас позаботились разработчики 1С и придумали замечатльный метод ПолучитьИдентификаторПодписчикаУведомлений, который возвращает как раз то, что нам нужно. Казалось бы практически все готово, но тут начинается самое интересное. Смотрим, что данный метод доступен только на мобильном клиенте, и вдобавок в качестве параметра необходимо указывать какой-то НомерПриложенияGoogleCloud.  Получить его довольно просто. Для этого идем в Консоль разработчика Google, авторизуемся и попадаем на стартовую страницу. Тут необходимо создать новый проект.

Создаем проект в консоли разработчика Google

Мастер создания проектов попросить придумать проекту какое-либо имя (оно будет нужно только для того, чтобы отличать проекты в самой консоли) и согласиться с условиями гугла. После создания проекта уже можно посмотреть необходимый нам НомерПриложенияGoogleCloud. Для этого перейдем в панель администрирования проекта, а затем в настройки. 

Смотрим номер проекта

Попробуем теперь получить ИдентификаторПодписчикаДоставляемыхУведомлений, который доступен через менеджера доставляемых уведомлений, но вспомним, что это все доступно только на мобильном клиенте. Поэтому надо решить, как мы будем передавать полученный ИдентификаторПодписчикаДоставляемыхУведомлений на Сервер. Способов на самом деле достаточно, но я предлагаю использовать http-сервис. Естественно он должен быть создан на Сервере. Итак, создадим http-сервис, с корневым URL testpush и одним методом типа GET, в модуль которого поместим следующий код 

    ПараметрыЗапроса = Запрос.ПараметрыЗапроса;
	Если ПараметрыЗапроса.Количество() <> 1 Тогда
		Ответ = Новый HTTPСервисОтвет(400);
		Ответ.Заголовки.Вставить("Content-Type","text/text; charset=UTF-8");
		Ответ.УстановитьТелоИзСтроки("Неверное количество параметров.");
		Возврат Ответ;
	КонецЕсли;
	
	IDПодписчика = ПараметрыЗапроса.Получить("reginfo");
	
	Константы.IDПодписчика.Установить(Новый ХранилищеЗначения(IDПодписчика, Новый СжатиеДанных(9)));
	
	Ответ = Новый HTTPСервисОтвет(200);
	Ответ.Заголовки.Вставить("Content-Type","text/text; charset=UTF-8");
	Ответ.УстановитьТелоИзСтроки("Все прошло успешно.");
	Возврат Ответ;

 Что здесь происходит? Так как мы планируем, что этот сервис будет вызываться с МУ, то ожидаем от МУ 1 параметр reginfo (можно его сделать обязательными, или вообще использовать POST и передавать все в теле, но сейчас не про это) - это сериализованный объект ИдентификаторПодписчикаДоставляемыхУведомлений. Поместим все это в Хранилище значения и  запишем в константу, предварительно создав ее. Теперь наконец-то на сервере у нас будет нужный нам параметр для отправки, но пока у нас до сих пор нечего отправлять, да и неоткуда. Займемся этим вопросом и начнем делать конфигурацию для МУ. Так как объект ИдентификаторПодписчикаДоставляемыхУведомлений имеет переменчивую природу и реккомендуется его переодически обновлять то поступим следующим образом. В  модуле управляемого приложения поместим следующий код (конфигурация для МУ)

Процедура ПриНачалеРаботыСистемы()
	
	ОбновитьIDПодписчика();

	ПодключитьОбработчикОжидания("Подключаемый_ОбновитьIDПодписчика", 7200);
	
КонецПроцедуры

Процедура Подключаемый_ОбновитьIDПодписчика() Экспорт
	ОбновитьIDПодписчика();
КонецПроцедуры

Процедура ОбновитьIDПодписчика()

	#Если МобильноеПриложениеКлиент Тогда

		НомерПроекта = ОбщийМодульВызовСервера.ПолучитьНомерПроекта();
		
		Если ПустаяСтрока(НомерПроекта) Тогда
			Возврат		
		КонецЕсли; 
		
		Попытка
			IDПодписчика = ДоставляемыеУведомления.ПолучитьИдентификаторПодписчикаУведомлений(НомерПроекта);
		Исключение
			Возврат
		КонецПопытки;
		
		ПараметрыЗапроса = Новый Структура("АдресСервера, ИмяБазы, IDПодписчика");
		// указываем IP Сервера, он может быть как локальный, так и нет
		ПараметрыЗапроса.АдресСервера = "192.168.0.11";
		// имя базы, под которым она была опубликована на вэб сервере
		// о том, как выполнить публикацию информации в Интернете информации предостаточно
		ПараметрыЗапроса.ИмяБазы      = "base";
		ПараметрыЗапроса.IDПодписчика = IDПодписчика;
		
		ОбщийМодульВызовСервера.ОтправитьIDНаСервер(ПараметрыЗапроса);
		
	#КонецЕсли

КонецПроцедуры

Для того, чтобы IDПодписчика всегда был актуальным на Сервере, подключим обработчик ожидания, который будет получать "свежий" ИдентификаторПодписчикаДоставляемыхУведомлений и отправлять его на Сервер, кроме того получение и отправку будем вызывать при самом старте системы. Все эти операции можно выполнять в фоне, чтобы это было незаметно для пользователя. Важным моментом является то, что при вызове метода ДоставляемыеУведомления.ПолучитьИдентификаторПодписчикаУведомлений будет происходить обращение к серверам Google, поэтому на МУ должен быть доступен Интернет. Стоит заметить, что у меня не вышло получить таким образом IDПодписчика на вирутальном устройстве, все вываливалось в ошибку неправильного параметра НомерПроекта (может это как-то связано с ограничением бесплатного функционала Genymotion), но на реальном устройстве все прекрасно отрабатывает.  В общих модулях поместим следующий код.

ОМ Вызов сервера

Функция ПолучитьНомерПроекта() Экспорт

	Возврат Константы.НомерПроекта.Получить();

КонецФункции // ПолучитьНомерПроекта()

Процедура ОтправитьIDНаСервер(ПараметрыЗапроса) Экспорт
	
	ОбщийМодульСервер.ОтправитьIDНаСервер(ПараметрыЗапроса);	

КонецПроцедуры

ОМ Сервер

Процедура ОтправитьIDНаСервер(ПараметрыЗапроса) Экспорт
	
	ПараметрыЗадания = Новый Массив();
	ПараметрыЗадания.Добавить(ПараметрыЗапроса);
	ФоновыеЗадания.Выполнить("ОбщийМодульСервер.ОтправитьIDНаСерверВФоне", ПараметрыЗадания, , "ОтправкаIDПодписчика");

КонецПроцедуры

Процедура ОтправитьIDНаСерверВФоне(ПараметрыЗапроса) Экспорт
	
	Попытка
		Соединение = Новый HTTPСоединение(ПараметрыЗапроса.АдресСервера);
		// первым параметров HTTPЗапрос является адрес ресурса
		// в данном случае сначала идет имя серверной базы, под которым она опубликована на вэб-сервере
		// т.к. мы использовали http-сервис, то после имени идет служебный параметр hs
		// при создании http-сервиса мы указывали коревой URL - testpush 
		// т.к. в сервисе 1 нас всего один метод, и он имеет тип GET, то через знак ? укажем имя параметра reginfo
		// и далее сериализованный IDПодписчика
		// если все ок, то в браузере можно набрать полученный URL и на нашем Сервере все отработает как нужно
		Запрос 	   = Новый HTTPЗапрос(ПараметрыЗапроса.ИмяБазы + "/hs/testpush?reginfo="+Сериализовать(ПараметрыЗапроса.IDПодписчика));
		Запрос.Заголовки.Вставить("Content-Type","text/xml; charset=UTF-8");
		Соединение.ВызватьHTTPМетод("GET", Запрос);	
	Исключение
	КонецПопытки;

КонецПроцедуры
 
Функция Сериализовать(Данные)

	ОбъектXDTO = СериализаторXDTO.ЗаписатьXDTO(Данные);
	ЗаписьXML = Новый ЗаписьXML;
	ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь);
	ЗаписьXML.УстановитьСтроку(ПараметрыЗаписиXML);
	ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, ОбъектXDTO);
	Возврат ЗаписьXML.Закрыть();

КонецФункции // Сериализовать()

Теперь у нас все готово чтобы на Сервере наконец-то оказался ИдентификаторПодписчикаДоставляемыхУведомлений, запускаем мобильное приложение, указываем наш номер проекта, перезапускаем приложение и вуаля, на Сервере константа IDПодписчика теперь хранит что-то типа

<DeliverableNotificationSubscriberID xmlns="http://v8.1c.ru/8.3/data/ext" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
	<subscriberType>GCM</subscriberType>
	<deviceID>APA91bHaICui92Jdsbv9vrBQsmebjhXvEhUgswKRkCoFwFVHcrCR6RlRH0OqTYRNWUUoM19nv_emkL-OuLfuAwVZfz8u07SDLTwffphWJ71yzTn3YRAKL6M</deviceID>
	<applicationID>com.e1c.mobile</applicationID>
	<databaseID>7e874fd6-e97e-6c1f-ac33-683d141e189d</databaseID>
</DeliverableNotificationSubscriberID>

Сервер уже знает практически все, чтобы отправить пуш, поэтому вернемся к нему. В общей форме добавим следующий код

Уведомление.Получатели.Добавить(Десериализовать(Константы.IDПодписчика.Получить().Получить()));

Получаем из константы хранилище значения, а из него уже нашу сериализованную строку и десериализуем ее.

Функция Десериализовать(Данные, ТипПреобразования = Неопределено)

	ЧтениеXML = Новый ЧтениеXML;
	ЧтениеXML.УстановитьСтроку(Данные);
	ПрочитанныеДанные = СериализаторXDTO.ПрочитатьXML(ЧтениеXML, ТипПреобразования);
	ЧтениеXML.Закрыть();
	Возврат ПрочитанныеДанные;	

КонецФункции // Десериализовать()

Теперь у нас есть готовое к отправке пуш сообщение. Для отправки  необходимо использовать метод глобального контекста ОтправкаДоставляемыхУведомлений.Отправить.  В качестве первого параметра необходимо передать сформированный объект ДоставляемоеУведомление, а вот вторым параметром идет строка с ключом авторизации для подключения к службе доставки "Google Cloud Messaging" (из СП). Стоит заметить, что Google Cloud Messaging уже не получится использовать, т.к. гугл использует более новую технологию Firebase Cloud Messaging или просто FCM. Таким образом нам нужно получить этот заветный ключ авторизации у гугла. Для этого вернемся в консоль разработчика Google и перейдем по ссылке.

Переход к FCM

Перед нами откроется страница Firebase Cloud Messaging, там много чего интересно, но нам надо перейти в консоль.

Переход к консоли FCM

Добавим новый проект, указав имя, которое мы указывали при создании проекта в консоли разработичка гугл. После ввода первых символов мастер создания предложить выбрать этот проект. Соглашаемся, также выбираем страну и нажимаем Добавить FireBase. Псоле этого возвращаемся в консоль разработчика гугл (теперь панель управления консоли примет иной вид нежели ранее) и идем в раздел Учетные данные. Тут нас будет интересовать ключи API, а именно ключ сервера.

Ключ API

Копируем его, ведь именно он нам и нужен для отправки пуша, то есть это и есть ключ авторизации для подключения к службе доставки. Возвращаемся в конфигуратор Сервера и немного добавим кода в общей форме. В итоге код отправки push сообщения будет выглядеть следующим образом

    Уведомление                    = Новый ДоставляемоеУведомление;
    Уведомление.Заголовок		   = Заголовок;
	Уведомление.Текст			   = ТекстСообщения;
	Уведомление.Данные 			   = Данные;
	Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;
	Уведомление.Получатели.Добавить(Десериализовать(ПолучитьIDПодписчика()));
	ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, КлючСервера);

Где Заголовок, ТекстСообщения, Данные, КлючСервера - это реквизиты формы, а функция ПолучитьIDПодписчика возвращает значение одноименной константы. 

Настало время первого теста. Запускаем приложение на МУ, блокируем экран или сворачиваем приложение, открываем в режиме Предприятие конфигурацию Сервер и жмем Отправить.

Сервер

Ура, МУ прожужжал/пропищал или что-то в этом роде, в общем, все получилось, сообщение доставлено.

Телефон

Остался еще один небольшой нюанс. Пока толку от такого сообщения немного, приложение ничего не делает при получении пуша. Исправим этот момент. В конфигурации МУ, в модуле управляемого приложения в событие ПриСтартеСистемы добавим следующий код

#Если МобильноеПриложениеКлиент Тогда
	ДоставляемыеУведомления.ПодключитьОбработчикУведомлений("Подключаемый_ОбработкаУведомления");
#КонецЕсли

Процедура Подключаемый_ОбработкаУведомления 

Процедура Подключаемый_ОбработкаУведомления(Уведомление, Локальное, Показано) Экспорт

	// просто сообщим тест пуша
	Сообщить(Уведомление.Текст);

КонецПроцедуры

Теперь после отправки сообщения с сервера можно выполнить любые действия на клиенте. В данном случае мы просто покажем текст сообщения.

Финал

Вместо заключения

Firebase это не только отправка push сообщений, но как мимнимум позволяет работать с рекламой в мобильных приложениях (с этим пока не разбирался), и, наверно еще много чего интересного, так что есть чем заниматься, господа!

p.s. в архиве 2 конфигурации - Сервер и Клиент, код которых на 90% изложен в этой публикации. 

Скачать файлы

Наименование Файл Версия Размер
Push сообщения с использованием Firebase cloud message:
.zip 13,09Kb
06.04.17
21
.zip 13,09Kb 21 Скачать

См. также

Комментарии
1. Константин Гейнрих (CyberCerber) 186 06.04.17 15:03 Сейчас в теме
Быстро пробежался, может, не заметил... Какие преимущества у этого сервиса по сравнению с тем, что предоставляет сама 1С?
2. Николай Беляев (freez1301) 219 06.04.17 15:12 Сейчас в теме
А какой сервис у самой 1С? На сколько мне известно, то такого нет. Обращение идет к серверам гугла, эпла и т.д. Наоборот есть возможность это миновать, в менеджере отправки в методе Отправить есть возможность указать, что используется промежуточный сервис, но как это работает - не разбирался.
Еще можно напрямую через http-запрос отправить через любой сторонний сервис, но опять же не сервера 1С. Или быть может речь про локальные уведомления самой мобильной платформы?
3. Константин Гейнрих (CyberCerber) 186 06.04.17 15:29 Сейчас в теме
(2) Я говорю про этот сервис - https://pushnotifications.1c.com
Да, это промежуточный сервис, который обращается к нативным сервисам платформ.
Просто его настройка и использование намного проще, чем рассказано у вас в статье. Вот и интересуюсь, стоит ли оно того?
4. Николай Беляев (freez1301) 219 06.04.17 15:50 Сейчас в теме
(3) не знал про такой сервис от 1С, будет нужно - разберусь как им пользоваться. А так, мне думается, что все будет тоже самое, кроме получения ключа сервера и номера проекта. Если так, то в чем сложность моего способа?
5. Ruslan Ruslan (flyer) 202 06.04.17 16:36 Сейчас в теме
супер! надо обязательно протестировать функционал. штука однозначно нужная.
6. Кирилл (user665172_ya.kefimov) 06.04.17 19:06 Сейчас в теме
Вопрос, тестировали как ведет себя обработка пуш уведомления если мобильное приложение выгружено из памяти? Всмысле показывается ли пуш средствами ОС или будет показан только когда запустится мобильное приложение или вообще не будет показан?

Еще вопрос, пробовал ли оправлять пуш из консоли firebase?

И еще вопрос, пуш успешно получен когда мобильное приложение собрано сборщиком и установлен на девайс или установленным мибильным приложением в "режиме разработки"?
7. Николай Беляев (freez1301) 219 06.04.17 19:28 Сейчас в теме
(6) Если приложение выгружено из памяти, то ничего не происходит, к сожалению. Когда запускаешь 1С все сообщения приходят сразу. Хотя я где-то читал, что должны пуши приходить и когда выгружено приложение из памяти.
В консоли firebase не разбирался, пока не было времени и необходимости.
Пуш будет получен и если приложение собрано в apk и если опубликовано на вэб-сервере, т.е. в "режиме разработки" (в статье именно 2 вариант)
8. Кирилл (user665172_ya.kefimov) 06.04.17 19:56 Сейчас в теме
(7) Спасибо за ответы, пару недель тоже экспериментировал с пушами, делал все как в статье за исключением того, что пробные пуши отправлял прямо из консоли firebase. При этом консоль показывала что пуш отправлен, но мобильное приложение ни в какую не хотело его принимать. У меня все-таки подозрение, что в статье описана работа с GСM, а не FCM. Вроде разница между ними небольшая и пока в FCM сохраняется обратная совместимость с GCM, но все-такие какая-то разница есть. Например в проектах react-native требуются определенные телодвижения для перехода с GCM на FCM (правка файла манифеста приложения)
Если будет время прошу попробовать все-таки отправить пуш из firebase консоли (firebase консоль - Notifications - Новое сообщение) и посмотреть пример ли его мобильная платформа. Тогда поймем действительно ли мобильная платформа принимает именно FCM пуши.
9. Кирилл (user665172_ya.kefimov) 07.04.17 22:13 Сейчас в теме
Так, подтвердились нехорошие опасения. Мобильная платформа не видит FCM пушей, только GSM. У firebase на днях появилась замечательная фишка cloud functions. Их например можно использовать для отправки пушей мобильной платформе, триггером события при этом является изменение данных в узле firebase database. Так вот внутри этих cloud functions используются именно FCM, а не GCM. Я тестировал так: задеплоил простую функцию, собрал простое приложение на react-native. Так вот, это нативное приложение пуши из cloud function отправленные при помощи FCM принимает замечательно, а мобильное приложение нет =(
И я так понимаю в кишки мобильного приложения залезть не получится и поправить это, только ждать пока 1с это сами реализуют.
10. Андрей Лавренков (Lavrentyus) 21.04.17 14:30 Сейчас в теме
	Уведомление = Новый ДоставляемоеУведомление;
	Уведомление.Получатели.Добавить("12345);
	Уведомление.Текст = "Текст уведомления";
	Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.Нет;
	Уведомление.Наклейка = 2;
	
	ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, "PUSH_SRV_API_KEY_12345");
Показать


Получаю ошибку:

Ошибка при вызове метода контекста (Отправить)
ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, "PUSH_SRV_API_KEY_12345");
по причине:
Несоответствие типов (параметр номер '1')


Принимаемые типы первого параметра:

<Уведомление> (обязательный)

Тип: ДоставляемоеУведомление, Массив.


Что я делаю не так?
11. Николай Беляев (freez1301) 219 21.04.17 14:45 Сейчас в теме
(10) Судя по Вашему коду Вы в Получатели добавляете просто строку, а нужно ИдентификаторПодписчикаДоставляемыхУведомлений
Lavrentyus; +1 Ответить
12. Андрей Лавренков (Lavrentyus) 24.04.17 05:49 Сейчас в теме
13. Семён Павлюков (7OH) 31 04.07.17 10:11 Сейчас в теме
Нашёл вашу статью - хорошая статья, но успел всё сделать похожим способом.

Пока руки не дошли до полной реализации http сервера (чтобы весь ид передавать), сделал вот такую функцию для создания ИД на сервере по строке
&НаСервереБезКонтекста
Функция ПолучитьПолучателя(DeviceID, Type)
        
    xdtoПодписчик = ФабрикаXDTO.Создать(ФабрикаXDTO.Тип("http://v8.1c.ru/8.3/data/ext","DeliverableNotificationSubscriberID"));
    xdtoПодписчик.DeviceID = DeviceID;
    xdtoПодписчик.SubscriberType = ФабрикаXDTO.Создать(
					ФабрикаXDTO.Тип("http://v8.1c.ru/8.3/data/ext","DeliverableNotificationSubscriberType")
					, ?(Type = Перечисления.ТипыУстройств.Андроид, "GCM", "APNS")
	);
	
    НовыйСериализаторXDTO = Новый СериализаторXDTO(ФабрикаXDTO);
    Подписчик = НовыйСериализаторXDTO.ПрочитатьXDTO(xdtoПодписчик);
        
    Возврат Подписчик;
    
КонецФункции
Показать


Но на этапе получения исключённых
масИсключения = ОтправкаДоставляемыхУведомлений.ПолучитьИсключенныхПолучателей(НаборКонстант.КлючДляGOOGLE);


получаю ошибку
"Не переданы данные для авторизации в сервисе отправки уведомлений"

Ключик пробовал и "Ключ API 1" и серверный - всё равно реакция одна.

Может вы сможете подсказать, куда копать ?
14. Николай Беляев (freez1301) 219 04.07.17 11:36 Сейчас в теме
(13)
ПолучитьИсключенныхПолучателей

вроде как только для APNS работает эта штука, а Вы ключ гугл пытаетесь передать.
15. Семён Павлюков (7OH) 31 04.07.17 12:28 Сейчас в теме
(14) Спасибо большое за наводку - и действительно ведь - написано в мануале.
Теперь уже лучше - ошибка выглядит иначе
"Отправка сообщения 1 через GCM завершилась ошибкой: ключ отправителя не подходит для получателя"
Ну тут видимо всё же придётся передавать ИД целиком с сериализацией.
16. Сергей Вееров (odinassdeveloper) 20.11.17 18:44 Сейчас в теме
(15) Добрый день? Вам удалось разобраться с этой ошибкой? У меня есть 2 проекта: один был реализован 2 года назад и там пуши отправляются до сих пор, второй делаю сейчас и получаю эту же ошибку. Со стороны 1С у меня механизм идентичный, разница только в проектах Google (под новую задачу создал новый проект)
17. Семён Павлюков (7OH) 31 20.11.17 22:18 Сейчас в теме
(16) В целом да - разобрался. Там проблема была в том, что получение массива отключенных работает только на яблоках.
Могу поделиться примером базы - стучите.
18. Сергей Вееров (odinassdeveloper) 21.11.17 12:04 Сейчас в теме
(17) Спасибо, на свежую голову сам разобрался.
Подытожу для истории: получить ключ сервера для GCM API на данный момент можно только в Firebase console. Вот тут подробно расписано. Конкретно я споткнулся на том, что из-за всех этих экспериментов с проектами гугла и ключами для их API я забыл перегенерировать идентификатор мобильного клиента и он оставался подписан на другой проект гугла.
19. Евгений Трофимов (OnErrorResumeNext) 08.12.17 16:17 Сейчас в теме
(18)
Скажите пожалуйста, как именно перегенерировать идентификатор мобильного устройства? Какие действия сделать?
20. Сергей Вееров (odinassdeveloper) 08.12.17 16:50 Сейчас в теме
(19)
так
kyper89; OnErrorResumeNext; +2 Ответить
21. Максим Лёвочкин (frutty) 83 03.02.18 14:47 Сейчас в теме
(20) испробовал всякое, но так и не смог отправить (получить) сообщение

	Уведомление = Новый ДоставляемоеУведомление;	
	
	Для каждого IDGCM Из IDGCMs.IDGCM Цикл
	
	Уведомление.Получатели.Добавить(IDGCM.Получить());
	
	КонецЦикла;
	
	Уведомление.Заголовок = "Заголовок";
	Уведомление.Текст = "Текст";
	Уведомление.Данные = "654654";
	Уведомление.Наклейка = 2;
	Уведомление.ИнтервалПовтора = 0;
	Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;
	
	Если Уведомление.Получатели.Количество() > 0 Тогда
		Попытка
			мИсключенныеПолучатели = Новый Массив;
			мИнформацияОПроблемахОтправкиДоставляемыхУведомлений = Новый Массив;
			ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, "AIzaSyCp1J..............................jdazL8", мИсключенныеПолучатели,,мИнформацияОПроблемахОтправкиДоставляемыхУведомлений); 
			ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, "AAAApAOy1s4:..............................................................................................................................................VHePtr2APYA39UWA7rl8IM4e9GYPzf7", мИсключенныеПолучатели,,мИнформацияОПроблемахОтправкиДоставляемыхУведомлений); 
		Исключение

		КонецПопытки;
	КонецЕсли;
	
Показать


Пробовал ключ и новый и старый. По итогу в мИнформацияОПроблемахОтправкиДоставляемыхУведомлений получаю ошибку с "Не переданы данные для авторизации в сервисе отправки уведомлений.".
Что блин я не так делаю?
Прикрепленные файлы:
23. Тимур (tgnike) 01.03.18 10:07 Сейчас в теме
(21) Нужно в данные авторизации передать соответствие.
 
ДанныеАвторизации = Новый Соответствие;
ДанныеАвторизации.Вставить(ТипПодписчикаДоставляемыхУведомлений.GCM, КлючСервера);
ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, ДанныеАвторизации, ,,мИнформацияОПроблемахОтправкиДоставляемыхУведомлений); 
it@contlog.ru; +1 Ответить
53. Станислав Коляда (it@contlog.ru) 13.04.18 06:06 Сейчас в теме
(23)
ДанныеАвторизации = Новый Соответствие; ДанныеАвторизации.Вставить(ТипПодписчикаДоставляемыхУведомлений.GCM, КлючСервера);


Мне этот совет помог.
Пробовал
на 8.3.11 в режиме совместимости с 8.3.8 - работает.
на 8.3.8 без режима совместимости - работает.
на 8.3.8 в режиме совместимости с 8.3.7 НЕ работает с ошибкой "Ошибка работы с Интернет: Удаленный узел не прошел проверку"
на 8.3.7 без режима совместимости НЕ работает с ошибкой "Ошибка работы с Интернет: Удаленный узел не прошел проверку"

использовал все самые последние варианты работы на момент 04.2018. firebase.google.com длинный ключ сервера.

Скорее всего ниже совместимости с версией 8.3.8 отправка средствами 1с не работает.
22. Эдуард Максаков (maksakov.en@mmk.ru) 12.02.18 07:34 Сейчас в теме
Спасибо за статью. Все получилось. Только есть вопросы:

1. Зачем обновлять ПодключитьОбработчикОжидания("Подключаемый_ОбновитьIDПодписчика", 7200)?
IDПодписчика у меня уже неделю один и тот же.

2. Кому-то удалось все же получить Push при закрытом моб. приложении (у меня нет)?
Вот что написано здесь: http://v8.1c.ru/o7/201502push/index.htm:
Если мобильное приложение работает в фоновом режиме (неактивно) или вообще не исполняется (выгружено из памяти), то уведомление отображается операционной системой. При этом используется звуковое оповещение и наклейка. В iOS наклейка будет установлена у иконки мобильного приложения на домашнем экране, а в Android она задаёт число, которое будет отображено в сообщении на панели уведомлений. После того, как пользователь нажмёт на уведомление, будет активизировано (или запущено) мобильное приложение, и будет выполнен (если он подключён) обработчик уведомлений.
24. Дмитрий Виссаров (dvissarov5) 06.03.18 18:45 Сейчас в теме
Спасибо за статью. До этого все работало исправно, а потом случилось такая странность. (см. скриншот).
При этом с этой ошибка платформа предлагает завершить работу, в исключение в коде не уходит

Был до этого ключ GCM , потом импортировал в FCM и при этом все осталось так же
Самое интересное что иногда проходит push иногда нет.
И то ли проблема в нашем все таки окружении или в каких то изменениях у google.

Сделано все через объекты 1с
ОтправкаДоставляемыхУведомлений.Отправить(Уведомление,ДанныеАвторизации)


2. Непонятно что является ID проекта в FCM для получения идентификатора мобильного устройства , то ли Project ID , то ли Sender ID?
Прикрепленные файлы:
25. Oleg P (itoleg) 12.03.18 17:46 Сейчас в теме
Ошибка одинаковая.
проблема началась 27 февраля 2018 года
Ранее работало без збоя.
Решения в интернете не нашел.

Есть решение данной проблемы?


Платформа: 1С:Предприятие 8.3 (8.3.11.3034)
Конфигурация: Сервер
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: украинский (Украина), Сеанс: русский
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
12.03.2018 16:44:00
Ошибка работы с Интернет: Удаленный узел не прошел проверку
26. Дмитрий Ковальков (ikekoval) 82 12.03.18 19:01 Сейчас в теме
(25)
Есть решение данной проблемы?

Ошибка работы с Интернет: Удаленный узел не прошел проверку


Подпишусь на обновления в теме. Такая же ошибка возникла недавно
27. Дмитрий Ковальков (ikekoval) 82 13.03.18 09:23 Сейчас в теме
(25)Одноэсники рекомендуют в таком случае на сервере включить лог CAPI2 и искать ошибку в момент отправки пуша. Большинству помогла установка сертификата (ошибки на него указывал лог) во вложении (тип хранилища - локально.
Проблема в платформе, которая работает в режиме совместимости версии старше 8.3.7. Если есть возможность совместимость снять, то проверка сертификата будет выполняться средствами ОС.

Мне установка сертификата не помогла. Работаю с УПП в режиме совместимости 8.2.13. Сегодня отпишу по разбору лога.
Прикрепленные файлы:
GTSGIAG3.crt
Daimon; Коленкин Илья; odinassdeveloper; dvissarov5; +4 Ответить
28. Дмитрий Виссаров (dvissarov5) 13.03.18 09:59 Сейчас в теме
(27)
Спасибо.
Тоже увидели форум и там нашли решение. Нам установка сертификата помогла, мы в свое время заморочились и сняли совместимость.
https://partners.v8.1c.ru/forum/topic/1694511#prettyPhoto
Там есть вариант и без снятия совместимости через запросы напрямую, минуя объекты 1С. Идет активное обсуждение.
29. Дмитрий Ковальков (ikekoval) 82 13.03.18 11:00 Сейчас в теме
(28) С проблемой столкнулся только вчера вечером и для начала решил опробовать всё, что связано с ошибками сертификатов. По итогу скорее всего опишу прямой запрос т.к. в логах шаром покати, только ошибки при установке нового сертификата т.к. удостоверяющий центр не отвечает, а копать дальше уже сил нет =/
31. Viktor L (artist17) 19.03.18 08:46 Сейчас в теме
(27)Мне помогло установка сертификата и добавление в конец файла cacert.pem ключ сертификата Symantec Class 3 Secure Server CA - G4

-----BEGIN CERTIFICATE-----
MIIDujCCAqKgAwIBAgILBAAAAAABD4Ym5g0wDQYJKoZIhvcNAQEFBQAwTDEg­MB4G
A1UECxMXR2xvYmFsU2lnbiBSb290IENBIC0gUjIxEzARBgNVBAoTCkdsb2Jh­bFNp
Z24xEzARBgNVBAMTCkdsb2JhbFNpZ24wHhcNMDYxMjE1MDgwMDAwWhcNMjEx­MjE1
MDgwMDAwWjBMMSAwHgYDVQQLExdHbG9iYWxTaWduIFJvb3QgQ0EgLSBSMjET­MBEG
A1UEChMKR2xvYmFsU2lnbjETMBEGA1UEAxMKR2xvYmFsU2lnbjCCASIwDQYJ­KoZI
hvcNAQEBBQADggEPADCCAQoCggEBAKbPJA6+Lm8omUVCxKs+IVSbC9N/hHD6­ErPL
v4dfxn+G07IwXNb9rfF73OX4YJYJkhD10FPe+3t+c4isUoh7SqbKSaZeqKeM­WhG8
eoLrvozps6yWJQeXSpkqBy+0Hne/ig+1AnwblrjFuTosvNYSuetZfeLQBoZf­Xklq
tTleiDTsvHgMCJiEbKjNS7SgfQx5TfC4LcshytVsW33hoCmEofnTlEnLJGKR­ILzd
C9XZzPnqJworc5HGnRusyMvo4KD0L5CLTfuwNhv2GXqF4G3yYROIXJ/gkwpR­l4pa
zq+r1feqCapgvdzZX99yqWATXgAByUr6P6TqBwMhAo6CygPCm48CAwEAAaOB­nDCB
mTAOBgNVHQ8BAf8EBAMCAQYwDwYDVR0TAQH/BAUwAwEB/zAdBgNVHQ4EFgQU­m+IH
V2ccHsBqBt5ZtJot39wZhi4wNgYDVR0fBC8wLTAroCmgJ4YlaHR0cDovL2Ny­bC5n
bG9iYWxzaWduLm5ldC9yb290LXIyLmNybDAfBgNVHSMEGDAWgBSb4gdXZxwe­wGoG
3lm0mi3f3BmGLjANBgkqhkiG9w0BAQUFAAOCAQEAmYFThxxol4aR7OBKuEQL­q4Gs
J0/WwbgcQ3izDJr86iw8bmEbTUsp9Z8FHSbBuOmDAGJFtqkIk7mpM0sYmsL4­h4hO
291xNBrBVNpGP+DTKqttVCL1OmLNIG+6KYnX3ZHu01yiPqFbQfXf5WRDLenV­OavS
ot+3i9DAgBkcRcAtjOj4LaR0VknFBbVPFd5uRHg5h6h+u/N5GJG79G+dwfCM­NYxd
AfvDbbnvRG15RjF+Cv6pgsH/76tuIMRQyV+dTZsXjAzlAcmgQWpzU/qlULRu­JQ/7
TBj0/VLZjmmx6BEP3ojY+x1J96relc8geMJgEtslQIxq/H5COEBkEveegeGT­Lg==
-----END CERTIFICATE-----
32. Дмитрий Ковальков (ikekoval) 82 19.03.18 12:33 Сейчас в теме
(31) Спасибо, но мне помогла полумера с сертификатом =) Прямой запрос, к слову, тестировали... Не получилось ибо запрос всё равно сервер отправляет, а сертификата нет.

Сервер (2008R2) с которого push перестали отправляться. Платформа 8.3.10.2466 совместимость 8.2.13 клиент-сервер, обычные формы.

Что сделал. Так как логи CAPI2 ничего не показывали - установил Wireshark на сервер 1с, запустил и в момент отправки push в глаза бросилась ошибка "Unknown CA". Смотрю адрес сервера с которого получил ответ, забиваю его в IE - открылся гугл. Захожу в сертификаты сайта, скачиваю, смотрю наименование - GIA3.

Окей. 1й вариант - вбить его название в гугле и искать ключ сертификата. 2й вариант - разбирать сертификат в .pem формат через openssl, но это черезчур для моих навыков. 3й вариант - спросить на форуме, как я и поступил.

Ключ сертификата в спойлере. Если вбить в поисковик 1ю строку, то можно убедиться, что в инете их выкладывают и не составит труда найти его без помощи форумов.

-----BEGIN CERTIFICATE-----
MIIDujCCAqKgAwIBAgILBAAAAAABD4Ym5g0wDQYJKoZIhvcNAQEFBQAwTDEg­MB4G A1UECxMXR2xvYmFsU2lnbiBSb290IENBIC0gUjIxEzARBgNVBAoTCkdsb2Jh­bFNp Z24xEzARBgNVBAMTCkdsb2JhbFNpZ24wHhcNMDYxMjE1MDgwMDAwWhcNMjEx­MjE1 MDgwMDAwWjBMMSAwHgYDVQQLExdHbG9iYWxTaWduIFJvb3QgQ0EgLSBSMjET­MBEG A1UEChMKR2xvYmFsU2lnbjETMBEGA1UEAxMKR2xvYmFsU2lnbjCCASIwDQYJ­KoZI hvcNAQEBBQADggEPADCCAQoCggEBAKbPJA6+Lm8omUVCxKs+IVSbC9N/hHD6­ErPL v4dfxn+G07IwXNb9rfF73OX4YJYJkhD10FPe+3t+c4isUoh7SqbKSaZeqKeM­WhG8 eoLrvozps6yWJQeXSpkqBy+0Hne/ig+1AnwblrjFuTosvNYSuetZfeLQBoZf­Xklq tTleiDTsvHgMCJiEbKjNS7SgfQx5TfC4LcshytVsW33hoCmEofnTlEnLJGKR­ILzd C9XZzPnqJworc5HGnRusyMvo4KD0L5CLTfuwNhv2GXqF4G3yYROIXJ/gkwpR­l4pa zq+r1feqCapgvdzZX99yqWATXgAByUr6P6TqBwMhAo6CygPCm48CAwEAAaOB­nDCB mTAOBgNVHQ8BAf8EBAMCAQYwDwYDVR0TAQH/BAUwAwEB/zAdBgNVHQ4EFgQU­m+IH V2ccHsBqBt5ZtJot39wZhi4wNgYDVR0fBC8wLTAroCmgJ4YlaHR0cDovL2Ny­bC5n bG9iYWxzaWduLm5ldC9yb290LXIyLmNybDAfBgNVHSMEGDAWgBSb4gdXZxwe­wGoG 3lm0mi3f3BmGLjANBgkqhkiG9w0BAQUFAAOCAQEAmYFThxxol4aR7OBKuEQL­q4Gs J0/WwbgcQ3izDJr86iw8bmEbTUsp9Z8FHSbBuOmDAGJFtqkIk7mpM0sYmsL4­h4hO 291xNBrBVNpGP+DTKqttVCL1OmLNIG+6KYnX3ZHu01yiPqFbQfXf5WRDLenV­OavS ot+3i9DAgBkcRcAtjOj4LaR0VknFBbVPFd5uRHg5h6h+u/N5GJG79G+dwfCM­NYxd AfvDbbnvRG15RjF+Cv6pgsH/76tuIMRQyV+dTZsXjAzlAcmgQWpzU/qlULRu­JQ/7 TBj0/VLZjmmx6BEP3ojY+x1J96relc8geMJgEtslQIxq/H5COEBkEveegeGT­Lg==
-----END CERTIFICATE-----


Дописал его в cacert,pem. УБЕДИЛСЯ, что дата изменения у файла обновилась и только тогда перезапустил 1с сервер (не факт, что требуется). Вуаля, вопрос решён.

Всем добра!
Прикрепленные файлы:
30. Oleg P (itoleg) 13.03.18 15:52 Сейчас в теме
Смотрю, проблема существует и актуальна. полумеры с сертификатом не помогают.

Также решил описать прямой запрос.
Пока есть ошибки.
Может скооперироваться та довести до логической работы прямой запрос.
Вот мой текст запроса:

ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " ", Истина));   
	СтруктураЗапроса = Новый Структура;  
	Данные = Новый Структура;
	СтруктураЗапроса.Вставить("data", Новый Структура("message,title","GCM Notifier:Message Success","GCM Notifier:Title Success"));
	Данные = Новый Структура;
	Данные.Вставить("title","GCM Notifier:Title Success");
	Данные.Вставить("body", "GCM Notifier:Message Success");
	Данные.Вставить("sound","default");
	Данные.Вставить("badge","1");
	СтруктураЗапроса.Вставить("notification", Данные);
	
	//Можно так
	//СтруктураЗапроса.Вставить("to", "APA91bFFUQHGAOXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX­XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXiA");//То что генерируется в мобильном устройсве
	
	//Если отмпарвка нескольким то 
	массивИД    = Новый Массив; 
	массивИД.Добавить("APA91bFFUQHGAOXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX­XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXiA");//То что генерируется в мобильном устройсве
	СтруктураЗапроса.Вставить("registration_ids", массивИД);
	
	СтруктураЗапроса.Вставить("ApplicationID", "com.e1c.mobile");
	ЗаписатьJSON(ЗаписьJSON, СтруктураЗапроса);
	strJSON = ЗаписьJSON.Закрыть();

	Соединение = Новый HTTPСоединение("gcm-http.googleapis.com/gcm/send");
	HTTPЗапрос = Новый HTTPЗапрос(); 
	HTTPЗапрос.Заголовки.Вставить("Content-type", "application/json");
	HTTPЗапрос.Заголовки.Вставить("Authorization", "key=AIzaXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX9o");//Ключ Google
	HTTPЗапрос.УстановитьТелоИзСтроки(strJSON,КодировкаТекста.UTF8,ИспользованиеByteOrderMark.НеИспользовать);
	ОтветHTPP = Соединение.ОтправитьДляОбработки(HTTPЗапрос);
	
	Сообщить(ОтветHTPP.ПолучитьТелоКакСтроку());
	
	//Ответ
	//{"multicast_id":5396816832955369423,"success":0,"failure":1,"canonical_ids":0,"results":[{"error":"MismatchSenderId"}]}
Показать
50. Дмитрий Гостищев (Dimon93dimon) 02.04.18 19:21 Сейчас в теме
(30) Я вот не понимаю, что делаю не так. Возвращает ошибку:

Отправка сообщения 1 через GCM завершилась ошибкой: <HTML>
<HEAD>
<TITLE>Unauthorized</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000">
<H1>Unauthorized</H1>
<H2>Error 401</H2>
</BODY>
</HTML>
user932300; +1 Ответить
51. Андрей (user623969_dusa) 02.04.18 21:57 Сейчас в теме
(50) на старых платформах данные авторизации лучше передавать строкой а начиная с совместимости 8.3.10 через соответствие
52. Дмитрий Гостищев (Dimon93dimon) 03.04.18 12:30 Сейчас в теме
(51)В этом и проблема. использую соответствие и не использую режим совместимости. Платформа 8.3.12.
57. Алексей Фроликов (user932300) 18.05.18 18:04 Сейчас в теме
(52)
м и проблема. использую соответствие и не использую режим совместимости. Платформа 8.

Lvbnhbq?
(52)Дмитрий, вам удалось решить данную проблему?
У меня такая же ситуация
56. Роман Дик (user872194) 10.05.18 09:56 Сейчас в теме
(30)
Может скооперироваться та довести до логической работы прямой запрос.
Вот мой текст запроса:


Oleg P, Получилось в итоге отправить таким запросом на андроид?
33. Эдуард Максаков (maksakov.en@mmk.ru) 19.03.18 13:05 Сейчас в теме
Сначала все работало, потом стало выдавать
Ошибка работы с Интернет: Удаленный узел не прошел проверку

обновил платформу до 8.3.11.3034 теперь такая ошибка у меня:

{ОбщаяФорма.ОтправитьPushсообщение.Форма(41)}: Ошибка при вызове метода контекста (Отправить)
ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, ЭтотОбъект.КлючСервера);
по причине:
Не переданы данные для авторизации в сервисе отправки уведомлений.
34. Эдуард Максаков (maksakov.en@mmk.ru) 19.03.18 13:37 Сейчас в теме
Если сделать, так то тоже ошибка
ОтправкаДоставляемыхУведомлений.ПолучитьИсключенныхПолучателей(КлючСервера)

Не переданы данные для авторизации в сервисе отправки уведомлений
35. Андрей (user623969_dusa) 21.03.18 12:45 Сейчас в теме
аналогичная ошибка - перскочил платформу - если бы остался на 8.3.8 все бы работало
36. Андрей (user623969_dusa) 21.03.18 13:17 Сейчас в теме
возникло предположение а не проблема ли это различия мобильной платформы и стационарной ид подписчика то получается в платформе 8.3.8 например и естественно посылая пуш с 8.3.11 будет ошибка сертификата - есть у кого время проверить гипотезу?
40. Андрей (user623969_dusa) 22.03.18 18:18 Сейчас в теме
(36) установка мобильной платформы 8.3.11 картины не меняет с 8.3.11 стационарной ошибка а на 8.3.8 и даже 8.3.9 работает
37. Эдуард Максаков (maksakov.en@mmk.ru) 22.03.18 07:09 Сейчас в теме
В 8.3.10 ошибка: Ошибка работы с Интернет: Удаленный узел не прошел проверку (раньше не было ошибок, до 8 марта)

После этой ошибки я обновил платформу на 8.3.11, ошибка: Не переданы данные для авторизации в сервисе отправки уведомлений.

Приложения для мобильника я не менял, ID подписчика всегда выдает один и тот же, он не изменен.

Может настало время платить за сервис google?
38. Андрей (user623969_dusa) 22.03.18 09:23 Сейчас в теме
(37) точно гугл не причем если локально запуститься на 8.3.8 отправка работает
39. Илья Коленкин (Коленкин Илья) 15 22.03.18 16:48 Сейчас в теме
запустил под 8.3.8 без использования режима совместимости ошибка пропадает но к сожалению не могу позвонить отключить совместимость. Есть еще другие решения этой задачи?
41. Андрей (user623969_dusa) 22.03.18 18:26 Сейчас в теме
(39) установка сертификата выше по сообщениям сработала GTSGIAG3.crt

и еще замечание
//так работает
ДанныеАвторизации = Новый Соответствие;
ДанныеАвторизации.Вставить(ТипПодписчикаДоставляемыхУведомлений.GCM, Ключ);
ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, ДанныеАвторизации);
//а так можно было раньше, больше не работает
//ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, Ключ);
Коленкин Илья; +1 Ответить
43. Илья Коленкин (Коленкин Илья) 15 23.03.18 11:10 Сейчас в теме
Установил сертификат. версия 8.3.10.2667, переписал код - Все работает.
44. Сергей Вееров (odinassdeveloper) 23.03.18 17:24 Сейчас в теме
(43)
ановил сертификат. версия 8.3.10.2667, переписал код

А режим совместимости какой?
45. Илья Коленкин (Коленкин Илья) 15 23.03.18 17:31 Сейчас в теме
(44) РежимСовместимости 8.3.6.
47. Сергей Вееров (odinassdeveloper) 23.03.18 17:52 Сейчас в теме
(45) Еще раз уточню:
1. Установили сертификат из (27)
2. Сделали вызов как в (39)
3. Режим совместимости оставили 8.3.6
4. Платформа 8.3.10.2667
И все работает?
И какая у Вас ОС?
48. Андрей (user623969_dusa) 23.03.18 21:18 Сейчас в теме
(44) мне нужна совместимость 8.3.8 всего то но проблема возникла у тех кто обновил платформу на 8.3.10 она возникла не просто из-за повышения совместимости а из-за смены платформы, с 8.3.9 не пробовал
49. Дмитрий Ковальков (ikekoval) 82 24.03.18 10:27 Сейчас в теме
(48) Неправда. Проблема возникла не из-за обновления платформы, а на пустом месте. Пришло время и старый сертификат истёк. Для сервера мало кто следит за сроками сертификатов.
Вопрос уже был решен.
Если режим совместимости 8.3.7+ то ищем сертификат GIA3 в консоле certmgr.msc и проверяем даты. Просроченный обновляем.
Если 8.3.7 и менее, то пишем ключ сертификата в cacert.pem
dvissarov5; Коленкин Илья; +2 Ответить
54. Алексей Шачнев (saa@kuzov.org) 27.04.18 00:59 Сейчас в теме
ОС Windows 10 и Windows 2016 Server
Платформа 8.3.11 и 8.3.12 (последние с сайта).
Попытка отправить push на Андроид.

На строке

ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, ДанныеАвторизации, , , МассивОшибокОтправкиPUSH);


тонкий клиент просто крашится, и Windows предлагает "отладка" или "закрыть программу".

В технологическом журнале пусто.

Кто-нибудь сталкивался?
55. Роман Дик (user872194) 08.05.18 12:00 Сейчас в теме
привет всем! много ваших советов помогло. но столкнулся с такой штукой. 1с-ка отправляет уведомление но приложение не отображает текст(пишет null). но когда отправляю с разных сайтов все получается. в чем может быть дело?
Уведомление                    = Новый ДоставляемоеУведомление;
	Уведомление.Заголовок		   = "111";
	Уведомление.Текст			   = "123"; 
	Уведомление.Данные			   = "213"; 
	Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;
	
	xdtoПодписчик = ФабрикаXDTO.Создать(ФабрикаXDTO.Тип("http://v8.1c.ru/8.3/data/ext","DeliverableNotificationSubscriberID"));
	xdtoПодписчик.DeviceID = "ID1";
	xdtoПодписчик.SubscriberType = ФабрикаXDTO.Создать(ФабрикаXDTO.Тип("http://v8.1c.ru/8.3/data/ext","DeliverableNotificationSubscriberType"), "GCM");
	НовыйСериализаторXDTO = Новый СериализаторXDTO(ФабрикаXDTO);
	Подписчик = НовыйСериализаторXDTO.ПрочитатьXDTO(xdtoПодписчик);
	Уведомление.Получатели.Добавить(Подписчик);
	ДанныеАвторизации = Новый Соответствие;
	ДанныеАвторизации.Вставить(ТипПодписчикаДоставляемыхУведомлений.GCM, "ID2");
	МассивУв=Новый массив;
	МассивУв.Добавить(Уведомление);
	ОтправкаДоставляемыхУведомлений.Отправить(МассивУв, ДанныеАвторизации);
	
	

Показать
58. Daimon (Daimon) 22.05.18 17:09 Сейчас в теме
Спасибо, автору!!! После танцев с бубнами, но таки взлетело!
8.3.12.1440 (без режима совместимости) и 8.3.11.61 (мобильная). Сертификат безопасности понадобился.
59. Роман Здоркин (r.zdorkin) 18.06.18 13:29 Сейчас в теме
пробую сделать то же самое только для iOS
в итоге не получается отправить сообщение.
на сколько я знаю для отправки уведомления APNS необходимо в операторе во второй параметр "ДанныеАутентификации"

ОтправкаДоставляемыхУведомлений.Отправить(Уведомление, ДанныеАутентификации);


подсунуть Файл сертификата (а не ключСервера, как это на андроиде), необходимый для подключения к службе доставки "Apple Push Notification Service" (расширение .pem). у кого-то получилось это сделать, если да, то какие были особенности, у меня что-то никак не взлетит и сертификат сгенерил и подсунул его в виде макета, но уведомление не проходят, ошибок со стороны 1с не выходит
Оставьте свое сообщение