Голосовой помощник "Ванесса"

Программирование - Мобильные приложения

14
Многие крупные компании разрабатывают различных “помощников” - siri, cortana, google now, alexa, bixby и.т.д. Помощниками не пользуюсь с тех пор, как увидел, что умный помощник от google разобрался, где мой дом и где работа, пришлось отключить. Использование помощника, чтобы узнать погоду и другие основные функции, мне малоинтересны. Гораздо интересней сделать своего “помощника” на 1С.

У всех помощников есть имена, “Ванесса“, думаю, будет лучшим.

По сути “помощник“ -  некий чат с ботом голосом. Реализовать текстовый чат с ботом не проблема для многих программистов. Всего пара реквизитов на форме и несколько функций. Не хватает лишь функций распознавания текста из голоса и наоборот. Реализовал эти функции в отдельном приложении Vanessa.apk

Пока много ума в помощницу не вкладывал.

Понимает только великий и могучий.

Пример общения на картинке ниже.

Вся Ванесса занимает пока 100 строчек кода 1С, конечно это не нейронные сети, но все в ваших руках.

Основное отличие от других помощников это то, что “Ванессу“ можно обучить.

На второй закладке можно добавить вопрос строчными буквами и соответствующий ответ. Ответ можно вводить любыми буквами. Имя “Ванесса“ вначале любого вопроса исключается при поиске ответа.

Научить можно как плохому, так и хорошему, создать для себя идеального собеседника.

Изначально, делал возможность голосового ввода сообщения для публикации //xn--80appelehcm.xn--p1ai/public/622737/

Про голосовой ввод написать что-то новое вряд ли возможно. Всегда думал, что “помощники“ это относительно просто, решил попробовать, и действительно, все очень просто.

Поправил баг в Vanessa.apk , приводивший к молчанию Ванессы.

Добавил возможность задать несколько ответов на один вопрос.

Также добавил возможность заполнения голосом и чтения заполненного.

Вложил в архив apk платформы для пользователей.

Имя “помошника“ мне не принципиально, возможно сделаю настройку в следующей версии. При определенных настройках TTS в андроид, Ванесса может отвечать по мужски.

Во вложенном архиве, Vanessa.apk, Vanessa.cf, com.PloAl.Vanessa-arm.apk, com.PloAl.Vanessa-x86.apk

  • Vanessa.apk - дополнительное приложение для распознавания голоса и чтения текста, не предназначено для самостоятеного запуска. Требуется только право записи голоса.
  • Vanessa.cf - конфигурация мобильного приложения
  • com.PloAl.Vanessa-arm.apk и com.PloAl.Vanessa-x86.apk - готовое для установки в телефон мобильное приложение. Никаких прав не требуется.

Приложению требуется android 5.0 и выше.

Для установки нужно перенести файлы "Vanessa.apk" и один из файлов "com.PloAl.Vanessa-arm.apk" или "com.PloAl.Vanessa-x86.apk", в мобильный телефон.

В зависимости от процессора смартфона ARM или x86. И установить перенесенные файлы.

Поговорите с вашим мобильным 1С :)

14

Скачать файлы

Наименование Файл Версия Размер
Голосовой помощник:
.zip 59,48Mb
28.05.17
13
.zip 1.1 59,48Mb 13 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. artbear 1098 26.05.17 16:32 Сейчас в теме
"безпорно" прикольно :) 0+, значит.
myALKleon; roofless; CyberCerber; Alexsh_kz; Steelvan; +5 Ответить
8. baton_pk 376 28.05.17 12:43 Сейчас в теме
(1) о, нет! "безпорно" совсем не означает "0+".
2. PloAl 125 26.05.17 16:48 Сейчас в теме
торопился не написал, через вторую закладку можно обучить любым ответам
главное вопрос только в нижнем регистре писать, т.е. мелкими буквами
3. TrinitronOTV 27.05.17 05:22 Сейчас в теме
А этот помощник тоже определяет, где мой дом и где работа?
4. PloAl 125 27.05.17 09:02 Сейчас в теме
Определить не сможет, только если вы сами не научите.
Vanessa.apk требуются права на RECORD_AUDIO, в Vanessa.cf все права выключены.
На второй закладке пишите вопрос "где мой дом" и ответ.
5. Evil Beaver 5371 28.05.17 08:03 Сейчас в теме
А выбранное имя специально перекликается с vanessa stack или просто так совпало?
6. PloAl 125 28.05.17 11:08 Сейчас в теме
так совпало, это просто имя созвучное с "One S"
7. Yashazz 2312 28.05.17 11:20 Сейчас в теме
"Hi, Ваня! Пупкин наносит ответный удар :)" (с)
9. PloAl 125 28.05.17 14:04 Сейчас в теме
Я всегда за дружбу технологий, платформ и.т.д.
10. ser6702 63 29.05.17 16:36 Сейчас в теме
+1 за алгоритм выбора имени
11. msergeev79 1 29.05.17 19:52 Сейчас в теме
Помощница безпорно? Не, не пойдет)
12. PloAl 125 29.05.17 20:02 Сейчас в теме
13. phoenix118 08.10.17 00:22 Сейчас в теме
А можно как-то увидеть исходник Vanessa.apk. был бы очень признателен )))
14. PloAl 125 08.10.17 10:12 Сейчас в теме
Там небольшой оверхед, можно использовать код ниже и дополнительный апк не нужен.
ЗПМУ = Новый ЗапускПриложенияМобильногоУстройства("android.speech.action.RECOGNIZE_SPEECH");
    ЗПМУ.ДополнительныеДанные.Добавить("android.speech.extra.LANGUAGE_MODEL","free_form");
    ЗПМУ.ДополнительныеДанные.Добавить("android.speech.extra.MAX_RESULTS",1);
    ЗПМУ.ДополнительныеДанные.Добавить("android.speech.extra.PROMPT","Говорите...");
    Если ЗПМУ.Запустить(Истина) = -1 Тогда
		Для Каждого Стр Из ЗПМУ.ДополнительныеДанные Цикл
			Если Стр.Ключ = "result" Тогда
				Наговоренное = Стр.Значение;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
Показать
mevgenym; phoenix118; +2 Ответить
15. PloAl 125 08.10.17 12:45 Сейчас в теме
Во втором условии "query" должно быть вместо "result"
Если Стр.Ключ = "query" Тогда
phoenix118; +1 Ответить
Оставьте свое сообщение