Сканирочка-8. Модуль подключения сканера штрихкода к произвольной конфигурации 1С

Оборудование - Сканер штрих-кода

93
Предлагаемая разработка позволяет организовать работу со сканером штрихкода, кардридером и прочим торговым оборудованием в произвольной конфигурации 1С за несколько минут. БЕСПЛАТНО.

Использование сканирования в авторской конфигурации 1С может быть самым широким: это и идентификация товаров, и персональные карты сотрудников, и штрихкодирование документов, и многое другое. Но программист при подключении сканера сталкивается, как минимум, с тремя проблемами:

1. Где взять драйвер?

2. Как его подключить к конфигурации?

3. Как не нарушить какое-либо лицензионное соглашение?

Предлагаемая разработка с необычным названием "Сканирочка" решает все эти вопросы. Драйвер используется бесплатный, семерочный. Модуль подключения написан с нуля, поэтому, вопрос №3 - также снимается: вы можете использовать разработку по своему усмотрению, в коммерческих и благотворительных целях, дарить, передавать, продавать... :)

Итак, чтобы подключить к своей восьмерочной конфигурации сканер штрихкода или кардридер, вам достаточно

  • Взять приложенную к этой публикации cf нашей "сканирочки"
  • Объединить ее со своей конфигурацией
  • Добавить в модуль приложения строки из модуля приложения скачанной cf
  • В модуле формы, где нужно проводить сканирование, писать так (*):

Процедура ВнешнееСобытие(Источник, Событие, Данные)
  Если Не ВводДоступен() Тогда
    Возврат;
  КонецЕсли;

  Оборудование.Обработать(Событие, Данные, ЭтаФорма);

КонецПроцедуры

Процедура ОбработатьШтрихКод(Данные) Экспорт
  Сообщить(Данные);
КонецПроцедуры

(*) ВнешнееСобытие - обработчик, подключаемый в свойствах формы. Вместо Сообщить(Данные) вставляем свой код обработки прочитанного штрихкода.

И это - все. Нам не нужно ничего никуда копировать: "сканирочка"  сделает все сама при запуске системы, запишет куда нужно драйвера, проведет регистрацию.

Для включения в программе работы со сканером в пользовательском режиме используется справочник "Подключения".

К разработке приложена тестовая форма, в которой можно проверить работу вашего сканера.


Правды ради нужно отметить, что разработанный нами модуль подключения сканера может использоваться для подключения любого торгового оборудования, а не только сканера. Более того, он поддерживает мультиподключение, например, работу с несколькими сканерами, несколькими принтерами чеков, если только разделение допустимо на уровне их драйверов и железа.

Также с его помощью можно сгенерировать произвольный штрихкод и включить его в табличный документ.

Для подключения произвольного торгового оборудования с помощью "сканирочки" у вас должен быть драйвер и внешняя обработка, управляющая этим драйвером. Обработка должна содержать в своем модуле три обязательных метода:

Подключить(Строка) - на вход подается некоторая строка состояния, определяемая из ваших настроек справочника Подключения для выбранного торгового оборудования.

Сброс() - сбрасывает состояние, включает готовность

Отключить() - отключает оборудование

Выбор используемого торгового оборудования производится на уровне пользователя с помощью справочника "Подключения".

 

 

Думаю, кому нужно - разберется. Либо задаст вопрос, на который с удовольствием отвечу.


Хочется отметить, что используемый алгоритм работы со сканером взят из разрабатываемой нами в настоящий момент новой кассовой программы "Кассирочка-8". Публикация этой программы на Инфостарте запланирована на начало апреля 2011 года. Поэтому, приглашаю всех заинтересованных принять участие в обсуждении этого проекта и последующем бесплатном тестировании. Переходите в блог с анонсом разработки "Кассирочка-8", оставляйте свои комментарии, получите возможность стать первыми пользователями программы.

 

93

Скачать файлы

Наименование Файл Версия Размер
Сканирочка
.zip 502,69Kb
21.03.11
625
.zip 502,69Kb 625 Скачать

См. также

Специальные предложения