Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІ: Документы

Публикация № 833371

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

обмен OData документ Open Data Protocol универсальный обмен

30
Продолжение статьи об универсальном обмене между идентичными конфигурации через REST интерфейс OData (https://infostart.ru/public/829356/). В части второй разберем особенности обмена документами.

 

ПРЕДЫДУЩАЯ ЧАСТЬ. ЧАСТЬ І. СПРАВОЧНИКИ

 

В части первой мы уже коротко выяснили что такое OData и описали некоторые общие процедуры и функции (в первой части я называл их служебными), мы используем (или даже расширим) для разработки модуля обмена документами следующие из них:

Функция ПолучитьКаналСвязиССерверомСбораДаних() // не изменится в этой статье
Функция ОпределитьШапкуЗапроса(GUID = "00000000-0000-0000-0000-000000000000") // не изменится в этой статье
Функция НормализироватьКОбмену(ЭтотРеквизит) // не изменится в этой статье

Функция СоздатьОписанияДополнительнихРеквизитов(СсылкаОбъекта, СписокСсылочных = 0) // расширится
Функция СоздатьОписанияТабличныхЧастей(СсылкаОбъекта, ПрефиксОбъекта, Тень = Ложь) // расширится

 

Вот так расширится и "главная" экспортная процедура отправки данных на сервер:

 
 Процедура ОтправитьНаСерверСбораДанных(СсылкаИсточник, DELETE = Ложь, ТипОбъекта = 0, БезКопии = Ложь, ОписаниеРеквизитовОтправки = Неопределено) Экспорт

Как видите добавились два новых параметры процедуры:
1) БезКопии - булево - по умолчанию - Ложь - мы начали передавать "ссылочные" реквизиты некоторых документов, но не хотели наполнять базу теневыми копиями, поэтому некоторые объекты НЕ копируются в тень для отложенной отправки;
2) ОписаниеРеквизитовОтправки - список значений - по умолчанию - Неопределено - не все реквизиты справочника для нас критически необходимо видеть на сервере, например, у нас на узле в справочнике ФизическиеЛица есть реквизиты ДатаРождения и ИНН, но на сервере нам необходимо видеть только реквизит ИНН - тогда в параметр ОписаниеРеквизитовОтправки мы передадим это:

Список = Новый СписокЗначений; 
Список.Добавить("ИНН"); // имя реквизита как в конфигураторе
 

Тело функции для обмена документом:

 
 Функция ДокументДоставленоУспешно(СсылкаДокумент, DELETE, Метод = "POST", Тень = Ложь, ФормироватьКлюч = Ложь, СписокРеквизитов = Неопределено)
Функция ДокументДоставленоУспешно(СсылкаДокумент, DELETE, Метод = "POST", Тень = Ложь, ФормироватьКлюч = Ложь, СписокРеквизитов = Неопределено)
	
	Если СсылкаДокумент.Пустая() Тогда
		Возврат Истина;
	КонецЕсли;
	
	Если Константы.СерверСбораДанныхОфлайн.Получить() И (НЕ Тень) Тогда // если связи нету можна просто перейти в офлайн используя  Константы.СерверСбораДанныхОфлайн.Установить(Истина)
		Возврат Ложь;
	КонецЕсли;	
	
	Связь = ПолучитьКаналСвязиССерверомСбораДаних(); // служебное - см. часть І
	
	ИмяДокумента = СсылкаДокумент.Метаданные().Имя;
	Если Тень Тогда
        // теневые копию я создавал в идентичном обьъкте как оригинальний док, 
        // только с префиксом «_с_». Зачем? Запрос по теневым копиям работают быстрее, 
        // и в случае успешной доставки теневой копию — копия удалялась
		ИмяДокумента = СтрЗаменить(ИмяДокумента,"_с_","");
	КонецЕсли;
	
	guid =  Строка(СсылкаДокумент.УникальныйИдентификатор());
	
    Заголовки = Новый Соответствие;
	Заголовки.Вставить("Accept", "application/atom+xml,application/xml");
	Заголовки.Вставить("Accept-Charset", "UTF-8");
	Заголовки.Вставить("Content-Type", "application/atom+xml");	
	Заголовки.Вставить("DataServiceVersion", "3.0;NetFx");	
	Заголовки.Вставить("MaxDataServiceVersion", "3.0;NetFx");	
	Заголовки.Вставить("User-Agent", "1C-Enterprise");	
	Заголовки.Вставить("Host", Связь.Сервер);

	Если DELETE Тогда // если удалить объект
        
        хАдресРесурса =  "/" + Связь.Порт + "/odata/standard.odata/Document_" + ИмяДокумента + "(guid'"+ guid + "')";
        Соединение = Новый HTTPСоединение(Связь.Сервер);		
    	Заголовки.Вставить("DELETE" + " /" + Связь.Порт + "/odata/standard.odata/Catalog_" + ИмяДокумента + "(guid'"+ guid + "')");

	    Попытка
		   хЗапрос = Новый HTTPЗапрос(хАдресРесурса, Заголовки); 
		   Ответ = Соединение.ВызватьHTTPМетод("DELETE", хЗапрос);
           Возврат Ответ.КодСостояния = 204 // случае успешного удаления сервер вернет код состояния  =204 
	    Исключение
           Возврат Ложь; 
		КонецПопытки;	

   Иначе // если создать/обновить объект	

		АдресРесурса = "/" + Связь.Порт + "/odata/standard.odata/Document_" + 
        ИмяДокумента + ?(Метод = "PUT", "(guid'" + guid + "')","");	
		
		ТекстЗапроса = ОпределитьШапкуЗапроса(guid); // служебное - см. часть І
		
        // соответствие стандартных реквизитов
		CписокCтандартныхРеквизитов  = СоздатьОписанияОбязательнихРеквизитовДокумента(СсылкаДокумент); // новое служебное - смотри далее
		Для Каждого ОписаниеРеквизита ИЗ CписокCтандартныхРеквизитов Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРеквизита.Ключ + ">" + СокрЛП(ОписаниеРеквизита.Значение) + "</d:" + ОписаниеРеквизита.Ключ + ">";	
		КонецЦикла;	
		
		// ссылочные реквизиты шапки(суфикс _Key)
		СписокКейс = Новый СписокЗначений();
		Если ИмяДокумента = "ЧекККМ" Тогда
			СписокКейс.Добавить("Магазин");
			СписокКейс.Добавить("Ответственный");
			СписокКейс.Добавить("Пользователь");
			СписокКейс.Добавить("Место");
		КонецЕсли;	
		
		// соответствие дополнительных реквизитов
		СписокДопРеквизитов  = СоздатьОписанияДополнительнихРеквизитов(СсылкаДокумент, СписокКейс); // служебное РАСШИРЕННОЕ - см. часть І
		Для Каждого ОписаниеДопРеквизита ИЗ СписокДопРеквизитов  Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеДопРеквизита.Ключ + ">" + СокрЛП(ОписаниеДопРеквизита.Значение) + "</d:" + ОписаниеДопРеквизита.Ключ + ">";	
		КонецЦикла;		
		
        // ссылочные реквизиты табличных частей(суфикс _Key)
		СписокКейсТЧ = Новый СписокЗначений();
		Если ИмяДокумента = "ЧекККМ" Тогда
			СписокКейсТЧ.Добавить("Номенклатура");
		КонецЕсли;	
        
    	// соответствие табличных частей 
		ОписаниеТабличныхЧастей = СоздатьОписанияТабличныхЧастей(СсылкаДокумент, "Document", Тень, СписокКейсТЧ); // служебное РАСШИРЕННОЕ - см. часть І
		Если НЕ ОписаниеТабличныхЧастей = "" Тогда
			ТекстЗапроса = ТекстЗапроса + ОписаниеТабличныхЧастей;
		КонецЕсли;	
		
		// ключ
		Если ФормироватьКлюч Тогда // все объекты которые не копируются в тень передаються с ключем - у нас это GUID Основного магазина
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:Магазин_Key>" + СокрЛП(Строка(Константы.ОсновнойМагазин.Получить().УникальныйИдентификатор())) + "</d:Магазин_Key>";	
		КонецЕсли;	
		
		ТекстЗапроса = ТекстЗапроса + "	
		|      </m:properties>	
		|   </content>	
		|</entry>";
		
		Соединение = Новый HTTPСоединение(Связь.Сервер);	
		
		Заголовки.Вставить("1C_OData_DataLoadMode", Истина); // ВАЖНО! Документы по старинке в режиме "ОбменДанными.Загрузка = Истина"
		Заголовки.Вставить(Метод + "  /" + Связь.Порт + "/odata/standard.odata/Document_" + ИмяДокумента + ?(Метод = "PUT", "(guid'" + guid + "')","") + " HTTP/1.1");	
		
		Попытка
			Запрос = Новый HTTPЗапрос(АдресРесурса, Заголовки);	
			Запрос.УстановитьТелоИзСтроки(ТекстЗапроса);	
			Ответ = Соединение.ВызватьHTTPМетод(Метод, Запрос);
			
			Если (Ответ.КодСостояния <> 201) И (Метод = "POST") Тогда // успешный POST когда КодСостояния = 201
				Возврат ДокументДоставленоУспешно(СсылкаДокумент, DELETE,"PUT", Тень, ФормироватьКлюч, СписокРеквизитов);
			ИначеЕсли (Ответ.КодСостояния <> 200) И (Метод = "PUT") Тогда // успешный PUT когда КодСостояния = 200
				Возврат Ложь
			Иначе	
				Возврат Истина
			КонецЕсли;
			
		Исключение
			Возврат Ложь;
		КонецПопытки;	
    КонецЕсли;

КонецФункции

 

 

Вот список необходимых функций обозначенных комментарием "новое служебное" или "служебное РАСШИРЕННОЕ" (не ругайте - знаю местам их можно и даже нужно оптимизировать):

 
 Функция СоздатьОписанияОбязательнихРеквизитовДокумента(СсылкаДокумент)
 
 Функция СоздатьОписанияДополнительнихРеквизитов(СсылкаОбъекта, СписокСсылочных = 0)
 
 Функция СоздатьОписанияТабличныхЧастей(СсылкаОбъекта, ПрефиксОбъекта, Тень = Ложь, СписокСсылочных = 0)

 

Ну, вроде по документу все. Ах да - а что делать если пользователь выполнит отмену проведения или вообще удалит документ? Ну, тогда нужно прописать в соответствующих местах модуля объекта документа следующее (документ исчезнет на сервере):

Процедура ОбработкаУдаленияПроведения(Отказ)
	
   ОбменССерверомСбораДанных.ОтправитьНаСерверСбораДанных(ЭтотОбъект.Ссылка,Истина,2);
	
КонецПроцедуры

 

СЛЕДУЮЩАЯ ЧАСТЬ. ЧАСТЬ ІІІ: РЕГИСТРЫ СВЕДЕНИЙ

 

Спасибо, что дочитали до конца! :)

30

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. logarifm 1063 22.05.18 17:34 Сейчас в теме
Я все понимаю.... Я с Украины причем западной. И ежедневно общаюсь на родном языке. Но так писать это перебор

ОписаниеСтандарнихРеквізивтів


Это не только не уважение к самому процессу стандарту именования переменных но и к другим участникам программирования. Исправьте пожалуйста это неподобство иначе реально влиплю минус.

Да еще и выкладываете на ресурс как учебный материал. Не портите и так тяжелые взаимоотношения таким написанием. Либо если так писать то пишите полностью на украинском но уже с английским диалектом. Как же так вообще реквизыты можно называть они и не русские и не украинские. Что это ?
V.Stavinsky; +1 Ответить
7. logarifm 1063 22.05.18 18:06 Сейчас в теме
А еще самое интересное то другое. Но мы уйдем щас в политику. При запрете 1С до этого практически во всех известных гос.структурах используется продукт именно этой фирмы. Типовые решения. Пенсионный фонд использует. А интересно то другое, кто выигрывает тендеры на написания софта гос.уччреждениям украинским. Отнють не САП и не оракл...
8. logarifm 1063 22.05.18 18:14 Сейчас в теме
Кстати в первой статье я тоже смотрю вы получили замечания относительно переменных. (и статья не исправлена)
V.Stavinsky; +1 Ответить
10. V.Stavinsky 220 22.05.18 19:00 Сейчас в теме
хотел бы поднять тему конвертации через odata - у кого какие идеи как можно это реализовать?
Оставьте свое сообщение

См. также

Конвертация ставок НДС: из Перечисления в Справочник (правила обмена в конвертации 2.0) 3

Статья Программист Нет файла v8 КД Россия НДС Бесплатно (free) Перенос данных из 1C8 в 1C8

При написании правил обмена между "более старой" и "более новой" конфигурациями можно столкнуться с тем, что в одной конфигурации ставки НДС - это перечисление, а в другой - справочник (или наоборот, но мой пример именно из перечисления в справочник). Ситуация несложная, но нестандартная, поэтому выкладываю работающий пример, может, кому пригодится.

09.11.2019    2053    vikulinamari    1       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Настройка синхронизации между конфигурациями Бухгалтерия для Беларуси 2.1 и Управление торговлей для Беларуси 3.4 2

Статья no Нет файла v8 БП3.0 УТ11 Беларусь Бесплатно (free) Перенос данных из 1C8 в 1C8

Пошаговое описание настройки типового обмена между конфигурациями Бухгалтерия для Беларуси 2.1 и Управление торговлей для Беларуси 3.4

21.10.2019    2611    OlesiaM    1       

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1 10

Статья Программист Нет файла v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free) Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    2873    Neti    0       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене 23

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    3507    handscenter    12       

Дозагрузка измененных данных при помощи КД2 7

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Иногда во время каких-то регламентных действий по обслуживанию базы(например, при обновлении измененной базы на много релизов) требуется обеспечить бесперебойность работы пользователей. Если конфигурации баз до и после идентичны, то тут сам Бог велел воспользоваться обработкой "ВыгрузкаЗагрузкаДанныхXML", либо такой же но с отбором(на Инфостарте есть такая). Но что если конфигурации баз различаются/значительно различаются? Ниже опишу, как вышел из положения я.

12.09.2019    2490    al_zzz    2       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке" 29

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    4024    ivanek    21       

Обмен данными через Web Сервисы 84

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    8228    user5300    31       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка и загрузка документов с движениями 13

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла задача перенести документы с движениями, но подменив организацию. Наткнулся на проблему с выгрузкой движений, опишу свой опыт.

02.09.2019    3092    human_new    7       

EnterpriseData – часть 3. Загрузка данных, идентификация объектов 65

Статья Программист Нет файла v8 v8::УФ 1cv8.cf ОС Бесплатно (free) Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    6572    ids79    7       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Перенос дополнительных реквизитов в Конвертации данных 2.0 18

Статья Программист Нет файла v8 КД Россия УУ Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    4580    vikulinamari    6       

Синхронизация данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл 2

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Публикация описывает последовательность синхронизации данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл.

23.04.2019    5448    saveliev    3       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Полезные приемы при работе с Конвертацией данных 2.1. Логирование, интерактивное управление, дозаполнение и постпроведение документов 45

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Некоторые полезные приемы для КД 2.1, которые могут пригодиться как при доработке типовых правил, так и самописных.

22.04.2019    5646    maks_20    9       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11732    m-rv    16       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Работа с ComОбъектом 1С 8.2; 8.3 104

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Определение типов и значений через COM соединение между конфигурациями.

15.04.2019    13526    vik070777    12       

Обмен данными между УПП 1.3.64.х и БП 3.0 по расписанию через Универсальный обмен данными + План обмена 3

Статья Программист Нет файла v8 УПП1 Россия Windows Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

Описание доработки конфигурации УПП 1.3.64.х для выполнения обмена данными по расписанию в БП 3.0. через обработку Универсальный Обмен Данными XML и План Обмена.

09.04.2019    3927    mrcamomile    0       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

RabbitMQ + Конвертация Данных 3.0 185

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    17001    barelpro    82       

Конвертация данных 2.1: поиск по условию 19

Статья Программист Нет файла v8 КД ERP2 Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Задача. При обмене документами "Реализация товаров и услуг", поиск контрагента осуществлять по полям "ИНН", "КПП". Если вид договора с комиссионером, то поиск осуществлять по полям "ИНН", "КПП", "Наименование".

15.01.2019    8502    wowik    13       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Заметки КД 2.1: Как передать файл, динамически создаваемый в источнике, в справочник присоединенных файлов приемника 25

Статья Программист Нет файла v8 КД Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

В БП 3.0 есть документ "Книга Продаж Для Передачи В ЭлектронномВиде" из которого выгружается XML файл. Задача: Нужно из БП 3.0 посредством правил обмена, вместе с документом книга продаж сформировать и перенести XML файл в базу приемник. В приемнике файл будет храниться в справочнике "Книга Продаж Присоединенные Файлы".

10.10.2018    6601    Viktor_Ermakov    6       

Практические рекомендации по настройке бесшовной интеграции 1С:ERP и 1С:Документооборот КОРП 41

Статья Системный администратор Программист Нет файла v8::Бизнес-процессы ERP2 Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

В настоящей статье мы пошагово рассмотрим, как настроить бесшовную интеграцию 1С:Документооброт КОРП (1С:ДО) с 1С:ERP.

28.09.2018    13403    Апрель-С    7       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Планы обмена 1С 178

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    38512    zhichkin    19       

Конвертация 2.0. Обмен данными между справочниками по сопоставлению артикулов с помощью регистра сведений (пример). 13

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример обмена данными между справочниками по сопоставлению артикулов с помощью регистра сведений

27.08.2018    5916    Lyubogradov.P    0       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Альтернатива переноса ТЗ в конвертации данных 2.1 5

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Здравствуйте уважаемые. Решил выложить альтернативный способ переноса данных в конвертации данных из источника к приемнику, с последующим сбором их в ТЗ в месте ПослеЗагрузки. Т.е.можно готовый перенесенный объект доработать либо создать что-то еще на базе данных. Метод сам разработан с учетом простого понимания Конвертации без использования всех её многочисленных тонкостей и сложностей. В примере рассматривается перенос Операции. И вот еще что. Я не привожу тут готовое решение, я всего лишь показываю концепцию того, как можно делать в КД. Без использования глобальных переменных.

20.08.2018    5114    dinopopyys    6       

Конвертация 2.0. Перенос независимого справочника в подчиненный (пример). 9

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса независимого справочника в подчиненный с помощью Конвертации 2.0.

15.08.2018    7052    Lyubogradov.P    6       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Конвертация 2.0. Перенос элементов и групп справочника, имеющих различный вид иерархии (пример). 12

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса справочника, имеющего различный вид иерархии, с помощью Конвертации 2.0.

13.08.2018    6809    Lyubogradov.P    0       

Повышаем эффективность разработки правил обмена 128

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    22637    olegtymko    47