Терминал сбора данных Opticon OPN 2001 , драйвер и обработка для 1с v7 v8

Оборудование - Терминал сбора данных

Opticon OPN 2001 1с Opticon 1с OPN2001 1с датаколлектор OPN 1с датаколлектор обработка 1с

9
Выгрузка-загрузка для терминала сбора данных OPTOCON OPN

 

Выгрузка-загрузка для терминала сбора данных OPTICON PHL OPN 2001

Обработка написана под платформу 1c v8.x v7.7  Драйвер для Opticon и внешняя обработка ert и epfКАК УСТАНОВИТЬ ДРАЙВЕР

скачать по ссылке http://old.opticon.com/uploads/Software/USB/Drivers/Installer.exe или выбрать продукт из Opticon Software Download и скачать необходимое

ПРОЧИТАТЬ ДАННЫЕ В ФАЙЛ

Запустить файл EGFS0080.exe и нажать СТАРТ (это прога в аттаче или на Opticon Software Download)


ЗАГРУЗИТЬ ДАННЫЕ

Запустить обработку, выбрать скачанный файл и нажать ВЫПОЛНИТЬ .

 

 

Можете скачать файл за SM или улучшить обработку с таким кодом:

 

 Перем  гПолучТекст,СтрЧислоСтрок ;



Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	Если НЕ ЗначениеЗаполнено(ПолеВводаОрганизация) Тогда
		    	Предупреждение("Заполнить ПолеВводаОрганизация");
				Возврат;
	КонецЕсли;
	
	Если НЕ ЗначениеЗаполнено(ПолеВводаСклад) Тогда
		    	Предупреждение("Заполнить ПолеВводаСклад");
				Возврат;				
	КонецЕсли;
	
	Если НЕ ЗначениеЗаполнено(ПолеВводаККМ) Тогда
		    	Предупреждение("Заполнить ПолеВводаККМ");
				Возврат;			
	КонецЕсли;

	
	 ЧтениеФайлаЗагрузки();
КонецПроцедуры



//******************************************* 



Функция ПреобразоватьДатуВидаИзСтроки(СтрокаДата)
	//Истина=-1;
	//Ложь=0;
    Разделитель="/";
	RegExp = Новый COMОбъект("VBScript.RegExp");
   //Параметры:
	RegExp.MultiLine = Ложь;  // истина — текст многострочный, ложь — одна строка
	RegExp.Global = Истина;   // истина — поиск по всей строке, ложь — до первого совпадения
	RegExp.IgnoreCase = Ложь; // истина — игнорировать регистр строки при поиске
	//Разбор строки вида 1,СЛОВО,(1+2); Маска для разделителя ',' [^\,]*"
	RegExp.Pattern = "[^\" + Разделитель + "]+";
	Matches = RegExp.Execute (СтрокаДата);
		//Сообщить(Matches.Item(0).Value+"="+Matches.Item(1).Value+"="+Matches.Item(2).Value); 
	 ДатаДок=Дата("20"+Matches.Item(2).Value,Matches.Item(0).Value,Matches.Item(1).Value) ;
	 
	Возврат ДатаДок;
	
 КонецФункции
 
 
 
 Функция строкуВМассив(СтрокаП,СтрокаРазделитель,СтрЧислоСтрок)
    Разделитель=";";
	RegExp = Новый COMОбъект("VBScript.RegExp");
	RegExp.MultiLine = Ложь;  // истина — текст многострочный, ложь — одна строка
	RegExp.Global = Истина;   // истина — поиск по всей строке, ложь — до первого совпадения
	RegExp.IgnoreCase = Ложь; // истина — игнорировать регистр строки при поиске
	RegExp.Pattern = "[^\" + Разделитель + "]+";
	Matches = RegExp.Execute (СтрокаП);
	

		//Сообщить(Matches.Item(0).Value+"="+Matches.Item(1).Value);  
	
	// 	ТабЗнач.НоваяСтрока();
	//ТабЗнач.Ид = Matches.Item(0).Value;
	//ТабЗнач.Штрих = СокрЛП(Matches.Item(1).Value);
	//ТабЗнач.Тайм1 = СокрЛП(Matches.Item(2).Value); 
	//ТабЗнач.Тайм2 =  СокрЛП(Matches.Item(3).Value); 
	  	
	Для Сч = 0 По Matches.Count - 1 Цикл 
	//	Сообщить(Matches.Item(Сч).Value);
	КонецЦикла;
	  
	ДатаВФормате=ПреобразоватьДатуВидаИзСтроки(Matches.Item(3).Value);
	
Запр = Новый Запрос("
 | ВЫБРАТЬ
 | 	Штрихкоды.Штрихкод,
 | 	Штрихкоды.ХарактеристикаНоменклатуры,
 | 	Штрихкоды.Владелец.Ссылка
 | ИЗ
 | 	РегистрСведений.Штрихкоды КАК Штрихкоды
 | ГДЕ
 | 	Штрихкоды.Штрихкод= &ТоварШК ");

Запр.УстановитьПараметр("ТоварШК", СокрЛП(Matches.Item(1).Value));
Выб = Запр.Выполнить().Выбрать();
РезультатЗапроса=Запр.Выполнить();
               	 
	Если  НЕ РезультатЗапроса.Пустой() Тогда
            ВремТоварТ = РезультатЗапроса.Выгрузить()[0];	
            ВремТовар=ВремТоварТ.ВладелецСсылка;
				Если ВремТовар.ЕдиницаХраненияОстатков.Пустая() Тогда
					Сообщить("        необходимо исправить единицы измерения у "+ВремТовар+"!") ;
				КонецЕсли;
	        ВремЕдиница=ВремТовар.ЕдиницаХраненияОстатков;
			ХарактеристикаШК=Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка();//ВремХарактеристика=ВремТовар.ХарактеристикаНоменклатуры;
	Иначе
		ВремКод     = "0"+СокрЛП(Matches.Item(1).Value);
		//Пока СтрДлина(ВремКод) 0 Тогда
		Поз = Найти(СтрКаталог, "\");
		Пока Поз > 0 Цикл
		   СтрКаталог = Прав(СтрКаталог, СтрДлина(СтрКаталог)-Поз);
		   Поз2 = Найти(ИсхСтр, СтрКаталог);
		   НовыйКаталог = Лев(ИсхСтр, Поз2-1);
		   Поз = Найти(СтрКаталог, "\");
		КонецЦикла;
	КонецЕсли;
	Возврат НовыйКаталог;
КонецФункции
 
Функция ВыборФайла(ВыбФайл, СтрЗаголовок, СтрПриглашение)
	СтандартнаяОбработка=ложь;
	Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Диалог.Заголовок = "Выберите файл";
	Диалог.ПолноеИмяФайла = ""; 
	Фильтр = "csv (*.csv)|*.csv"; 
	Диалог.Фильтр = Фильтр; 
    Диалог.МножественныйВыбор = Ложь;
	Диалог.Каталог = "C:\base1c\Retail_ToDay\";
	Если Диалог.Выбрать() Тогда
		ВыбФайлЗагрузки = Диалог.ПолноеИмяФайла;
	КонецЕсли;
КонецФункции
 
Процедура ВыборФайлаЗагрузки()
	ВыборФайла(ВыбФайлЗагрузки, "Выберете файл для загрузки", "Файл для загрузки");
КонецПроцедуры    
 


Функция ОбработкаСтроки(СтрокаВх)
		СтрокаВх=СтрЗаменить(СтрокаВх,"PM ","PM;");//AM 
		СтрокаВх=СтрЗаменить(СтрокаВх,"AM ","AM;");//AM
        СтрокаВх=СтрЗаменить(СтрокаВх,", ",";");
		СтрокаВх=СтрЗаменить(СтрокаВх,",",";");
	
//	Сообщить(СтрокаВх);  
строкуВМассив(СтрокаВх,";",0) ;

 
	  	
	
КонецФункции






Функция ПолучитьИмяФайла(ВыбФайл, Имя)
	
	
КонецФункции

Функция ЧтениеФайлаЗагрузки()
	Перем Имя;
	Если СокрЛП(ВыбФайлЗагрузки) = "" Тогда
	       	Сообщить("не выбран файл...") ;
		Возврат 0;
	КонецЕсли;             
			
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(СокрЛП(ВыбФайлЗагрузки));
 Для НомерСтроки=1 по Текст.КоличествоСтрок() Цикл
	ТекСтр = Текст.ПолучитьСтроку(НомерСтроки);
	Состояние("В файле прочитано строк "+НомерСтроки+" из "+Текст.КоличествоСтрок());			     
	ОбработкаСтроки(СокрЛП(ТекСтр));
 КонецЦикла;  
					
КонецФункции



Процедура Сформировать()
      ЧтениеФайлаЗагрузки();
КонецПроцедуры    


Процедура ПриОткрытии()


КонецПроцедуры

 

9

Скачать файлы

Наименование Файл Версия Размер
Загрузка и формирование ОТЧЕТ ККМ из заранее скачанных данных от OPN 2001
.zip 790,33Kb
14.01.14
12
.zip 790,33Kb 12 Скачать

См. также

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
0. Bublik2011 9 01.01.70 03:00 Сейчас в теме
Выгрузка-загрузка для терминала сбора данных OPTOCON OPN


Перейти к публикации

1. toshka 16.04.11 17:00 Сейчас в теме
Добрый день!

Обработка интересная.. Но написано "Формируется ТЗ: штрих, дата, время. "

А вот даты я там не нашла???
32. Bublik2011 9 15.01.13 14:02 Сейчас в теме
(1) toshka, да действительно, дату лучше REgExp VBA лучше вытаскивать. Это проще, но можно и преобразовать строковыми операторами формат даты OPN-2001

4:35:47 PM 7/28/12



Функция ПреобразоватьДатуВидаИзСтроки(СтрокаДата)
	         	
	 ПозицияПервогоЗнакаНайденной=  Найти(СтрокаДата,"M ");
	  КоличествоСимволовСтроке=СтрДлина(СтрокаДата); 
	ЦифрыНомера = Сред(СтрокаДата, ПозицияПервогоЗнакаНайденной+2,КоличествоСимволовСтроке-ПозицияПервогоЗнакаНайденной  );
	Год=(Прав(ЦифрыНомера,2));
	Месяц=СтрЗаменить(Лев(ЦифрыНомера,2)," ","");
	 ВходДня=Найти(ЦифрыНомера,"/");
	   ЦифраДня=Число(Сред(ЦифрыНомера,ВходДня+1,2));
	День=СтрЗаменить(ЦифраДня," ","");
	Год=("20"+Строка(Год));
	
	 ДатаДок=Дата(Год,Месяц,День,15,30,00) ;
	 Если Строка(ТипЗнч(ДатаДок))="Дата" Тогда
		Возврат ДатаДок; 
	Иначе 
		Сообщить("Неверно произошло преобразование входной строки:"+Строка(СтрокаДата));
		Возврат ТекущаяДата();
	 КонецЕсли;	 
	 Сообщить("ДатаДок: "+ Строка(ДатаДок));


Показать
2. Bublik2011 9 17.04.11 22:40 Сейчас в теме
Я грустно вздохнул и полез переписывать на 1с совместимый язык из черновика программы на AutoIt :oops:
3. toshka 18.04.11 06:12 Сейчас в теме
4. Tatitutu 3727 13.07.11 15:10 Сейчас в теме
глОбъектыOLE - это из откуда ?
5. DealMaker 14.07.11 14:36 Сейчас в теме
Спасибо большое!!! Обработка помогла!
6. Bublik2011 9 19.10.11 09:58 Сейчас в теме
Если честно, мне стыдно выкладывать файл. Суть моего изделия такова: формируется текстовый файл для стандартной обработки "импорт документов". Но т-а-а-к криво написано...((( Аж стыдно выкладывать. Стучитесь в E-Mail, отправлю as is, вполне работоспособное, с описанием.
7. Bublik2011 9 09.11.11 10:18 Сейчас в теме
Обработку Opticon OPN 2001 фирма 1с включила в джентельментский набор уже на платформе 1с8.2
8. navi 09.02.12 18:36 Сейчас в теме
Заранее извеняюсь если не совсем по теме.
Кто-то встречал тсд с wifi, так чтобы поддерживал терминальную сессию и непосредственно работал с 1с 7.7. Нужно для приемки товара на складе. Цена до 3000$
Заранее спасибо
14. elchinisa 30.03.12 22:29 Сейчас в теме
(8) navi, napiwi na email: elchin.isa@mail.ru
15. Bublik2011 9 31.03.12 17:53 Сейчас в теме
(14) elchinisa, какого xyz на E-Mail???
19. alsky-2003 29 01.04.12 04:34 Сейчас в теме
(8) navi, мы ставим чеще всего клиентам мотороллы symbol mc3190. там и wi-fi и rdp и цена до 3000$. за 3000$ машинка считывает уже и rfid метки. Работает на win ce. Вот только в терминалке решили не использовать - в оригинально варианте слишком все мелко на экране, неудобно работать. Мы берем проги: либо datamobile либо агент плюс.
30. Bublik2011 9 15.01.13 13:54 Сейчас в теме
(19) alsky-2003, Сердечное спасибо за файлы.

Но лучше всего наверно рассматривать этот датаколлектор как устройство ККМ-Offline
9. Ката174 19.02.12 04:33 Сейчас в теме
Большое человеческое спасибо!
10. denisvka 15.03.12 17:22 Сейчас в теме
Пишет, что работает в демонстрационном режиме. Замена Csp2.dll из архива SDK результата не дает. Помогите, пожалуйста.
31. Bublik2011 9 15.01.13 13:56 Сейчас в теме
(10) denisvka, Все работает. Возьмите обработки из джентльменского набора. Точнее из TradeWare. Подробности: (26)
11. Bublik2011 9 22.03.12 15:38 Сейчас в теме
Обошел проблему создания стоимости. Вряд-ли будут приобретать софт и ПО для девайса по цене 50% от стоимости последнего. Это такое с управляемыми формами и прочее. Можно решить проблему иначе.
0) Структура:
а)файл 0000000000592301 02_24_12 09_51_51.csv -> магазин №1 с кодом 01, время 24февраля
б)файл 0000000000592310 02_28_12 18_37_10.csv -> магазин №2 с кодом 10, время 28февраля
1) Запуск настройки даты и прочего \base1c\DataDownloader\OPN2001 Standard Demo\Kit\OPN2001.exe
2) Считать коды c:\base1c\DataDownloader\EGFS0080.exe в каталог
3) Считанный файл c:\base1c\Retail_ToDay\Извлечение Данных из файла и разнесение по пунктам продаж.exe
4) Обработкой вроде ИмпортНакладных_дляУТ10.epf загружаются сформированные в п.3 файлы типа 24-2-12.Txt. Нажатие кнопки "Создать Документ". Надо бы скриншотов или видео сделать?
5)Переключатели помучайте, лишние поля закомментируйте. Вопросы? Пишите в личку или сюда.
Прикрепленные файлы:
diskC_koren.zip
12. alsky-2003 29 28.03.12 19:53 Сейчас в теме
Тут прочел,что 1С включила обработку для OPN 2001 в "джентльменский набор" на платформе 8.2 А подскажете, что это за обработка? Для сканера 1С? или появились для ТСД?
13. alsky-2003 29 28.03.12 20:13 Сейчас в теме
я сегодня целый день пытался от всех поставщиков добитьсяответа - как эта хрень работает с 1С.Никто из крупных поставщиков не смог ничего ни предложить, ни найти в инете. Повезло, что есть ВЫ. Спасибо большое за обработку. А вот по поводу предыдущего вопроса и впрямь интересно. Кстати, еще вопрос: куда сохранять отсканированные данные, чтобы Ваша обработка их цепляла?
16. Bublik2011 9 31.03.12 17:56 Сейчас в теме
(13) alsky-2003, поверьте, меня тоже добила позиция ретайлеров про девайс - "простой накопитель". Да еще больше прибило, что разработка на управляемой форме с большой кнопкой "Выполнить сразу" стоит не меньше 1000 руб. Процентов 10-20 куда ни щло еще.. Наверно и в 8.3 не включат.. Да-а-а-а :(((
17. Bublik2011 9 31.03.12 18:05 Сейчас в теме
Распакуйте архив в корень диска. Прожкой Извлечение Данных из файла и разнесение по пунктам продаж.exe (экзешник из au3) из файла "0000000000592310 02_05_12 99_99_99.csv" создается куча файлов c:\base1c\Retail_ToDay\0000000000592310\07-01-2012.Txt Файлы типа 07-01-2012.Txt импортируются обработкой.

Могу мувик снять или подробнее инструкцию написать.

Хочу, чтобы обработка была полезна для Вас. Желаю написать понятным языком простую вещь - описание.
Прикрепленные файлы:
Извлечение Данных из файла и разнесение по пунктам продаж.exe
18. alsky-2003 29 01.04.12 04:27 Сейчас в теме
К сожалению или к сччастью, я не стал пользоваться Вашей обработкой, Василий. Я сам не программер, а руководитель, мне откровенно трудно вникать в нюансы программирования и есть привычка искать самое простое решение, поэтому я продолжил поиски. Нашел обработку какой-то фирмы на каком-то форуме. Регистрируешь dll-ки, положив их в папку bin, ставишь родные дрова для opn2001 и через обработку подключаешь opn как ТСД. Мигом заработала :). С удовольствием делюсь :). Поставщики в очередь выстроились за обработочкой:)
Прикрепленные файлы:
Opn2k1C.1.0.1.92.7z
smooth; Ката174; +2 Ответить
20. Ката174 02.04.12 01:57 Сейчас в теме
(18) alsky-2003, Перепробовала все. Работает в демо режиме((. Не подскажете, в чем может быть проблема. 1С 7.7 не типовая.
21. chegol 11.04.12 21:44 Сейчас в теме
(20) Ката174, Ну а что Вы хотели, Вам прорекламировали архив с платным решением, купите его у производителя и демо режим сможете отключить.
22. Ката174 11.04.12 22:03 Сейчас в теме
(21) chegol,
Терминал будет использоваться только при инвентаризации. Поэтому заморачиваться не стала. Будем сбрасывать данные из терминала в файл штатной программой, а потом в 1С считывать из файла в документ. Кстати, штатная программа может данные неоднократно добавлять в файл. Вот как то так. Когда впереди непреодолимое препятствие, приходится идти в обход)))
29. Bublik2011 9 15.01.13 13:52 Сейчас в теме
(20) Ката174, Никакой рекламы. Не все фирмы снабжают своих покупателей дисками с ПО. А уж куда выгружать - в "Реализация" или "Отчет продажи" - выбирайте сами.

Вообще, для правильного рассмотрения предлагаю этот OPN-2001 рассматривать как устройство для выдачи минимальной информации: Штрихкод и ВремяРегистрации

6934439702836, 4:35:47 PM 7/28/12


То есть выдало файлик вроде POS.REP как касса, а стандартная бесплатная обработка разнесла данные по документам. Единственное, только под свои нужды придется дописать.

Драйвер? Рассмотрите этот датаколлектор как устройство ККМ-Offline
23. alexandrguriev 06.10.12 20:44 Сейчас в теме
В итоге пришлось разработать драйвер подключения 1с самому. Кому интересно обращайтесь http://opn2001.at.ua/
27. Bublik2011 9 15.01.13 13:33 Сейчас в теме
(23) alexandrguriev, неужели не стыдно делать деньги на таком прекрасном и доступном OPN-2001? Вы бы людям предложили-бы обоснование необходимости применения ККМ Штрих-М или терминалов с ЖКИ.

Поймите-же, OPN-2001 - это игрушка. Если действительно уверены, что по воробьям лучше не палить из пушки, тогда применяйте OPN-2001.

Изврат: 1) купить накопитель за 3500руб и комплект драйверов за 2500руб
2) купить ТСД с ЖКИ от 7000руб или ПОС Штрих-М (в конфигурации похожей на нетбук))) за 8000руб

Выбирайте сами))) А пока вот можете денег дать за драйвер к OPN-2001 )) на http://opn2001.at.ua/
24. chegol 07.10.12 00:53 Сейчас в теме
Да уже давно сам написал, правда под розницу, но большего и не требовалось. Готов поделиться абсолютно бесплатно :) Драйвер OPN2001
25. toshka 21.10.12 10:56 Сейчас в теме
(24) Уважаемый Александр! Очень хотелось бы познакомиться с Вашим драйвером, но публикация не активна.

Буду очень благодарна если найдете время выслать. Заранее спасибо! REM02@yandex.ru Антонина

(24) chegol,
28. Bublik2011 9 15.01.13 13:35 Сейчас в теме
(24) chegol, я только за Ваш пост! Действительно, очень простое решение есть, гораздо проще. Удивительно просто и функционально.
33. nice.kid 31.07.13 18:33 Сейчас в теме
(28) нет ли у Вас случайно драйвера для OPN2001, о котором говорил chegol (24)?..
а то публикация не активна, автор не отвечает, а подключить датаколлектор очень надо.
34. Bublik2011 9 22.10.13 16:01 Сейчас в теме
Извините, (33) nice.kid, сразу не ответил, надо было в личку постучаться)


Информация-буклет по датаколлектору и драйвера - у производителя Opticon OPN2001В конце 2013 года эта ссылка была рабочей: http://www.opticon.com/OPN2001.aspx



Вот презентация девайса на русском Датаколлектор Opticon OPN2001

Особо не рассчитывайте на него, если много товаров с дополнительными характеристиками. Тогда лучше девайс для сбора ШК купить с дисплеем, в котором загружена база товаров. А пока, как накопитель ШК - это идеальное и замечательное устройство.
35. Bublik2011 9 22.10.13 16:08 Сейчас в теме
(33) nice.kid, Извините, забыл. Проблема с "лидирующим нулем" как-то сами решайте) Но менять настройки смысла не вижу, продавцы обязательно его разрядят и настройки "сбросятся". Прицепил к обработке выдаваемый дефолтный формат. В аттаче фото, прекрасно удается в "Розничные продажи" документы добавлять. Учитывать время продажи и т.п.
Прикрепленные файлы:
26. Bublik2011 9 15.01.13 11:50 Сейчас в теме
toshka, энтузиазма поубавилось по поводу API датаколлектора. Причина - информация либо загружается в датаколлектор, либо выгружается из датаколлектора. Если-бы она ХРАНИЛАСЬ в OPN-2001, действительно было-бы замечательно. А пока безопаснее как-то выгрузить файл и потом этот файл обработать.

Единственное, чего мне интересно - сделать работу этого датаколлектора простой. В аттаче - прикрепленная бработка.

Можете-ли Вы toshka, указать на недостатки этой обработки и таким образом сделать ее лучше?

Суть обработки - на основе стандартной. Файл из каталога формирует документ "Отчет о продажах". У меня на УТ10.3 пока работает))) С радостью перепишу ее под Ваши нужды в рамках этой публикации.

Вам скорее всего придется иметь Штрихкоды и цены товаров, еще сопоставлять склад-кассу-фирму и покопаться с процедурой

Процедура ЗаполнитьСтрокуТоварДокумет_ОтчетОРозничныхПродажах(док, т)
	
	  МетаданныеДокумента = док.Метаданные();
	 ИмяТабличнойЧасти="Товары";
	ТабличнаяЧасть = док[ИмяТабличнойЧасти]; 	
	товарыСтрока=док.Товары.Добавить();	
		 
	  // попробуем найти товар по штрихкоду
		Запрос = Новый Запрос();
		Запрос.Текст = "ВЫБРАТЬ Разрешенные Первые 1
		               |	Штрихкоды.Владелец КАК Владелец,
		               |	Штрихкоды.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры
		               |ИЗ
		               |	РегистрСведений.Штрихкоды КАК Штрихкоды
					   |ГДЕ
					   |	Штрихкоды.Штрихкод = &Штрихкод";
					   
		Запрос.УстановитьПараметр("Штрихкод", т[1]);
		РезультатЗапроса = Запрос.Выполнить();
		Если НЕ РезультатЗапроса.Пустой() Тогда
			
			СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];
			//УстановитьВТабличнойЧастиНоменклатуру(СтрокаТовара, СтрокаРезультата.Владелец, СтрокаРезультата.ХарактеристикаНоменклатуры);
			текТов=СтрокаРезультата.Владелец;
				Если СтрокаРезультата.ХарактеристикаНоменклатуры = Неопределено Тогда
					ХарактеристикаНоменклатурыТов = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка();
				Иначе
					ХарактеристикаНоменклатурыТов=СтрокаРезультата.ХарактеристикаНоменклатуры;
				КонецЕсли;
				
				
		товарыСтрока.Номенклатура=текТов;
	  	товарыСтрока.ЕдиницаИзмерения=текТов.ЕдиницаХраненияОстатков;
	товарыСтрока.Количество=1;
	товарыСтрока.Коэффициент=1;
	товарыСтрока.ХарактеристикаНоменклатуры=ХарактеристикаНоменклатурыТов;
	ЦенаТов=	Ценообразование.ПолучитьЦенуНоменклатуры(текТов, ХарактеристикаНоменклатурыТов, ПолеВводаСклад.ТипЦенРозничнойТорговли);
	товарыСтрока.Цена= ЦенаТов;
	
		Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("КодуККМ", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ВремяПродажи", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("НомерЧека", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("Ошибка", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда  		
	товарыСтрока.КодуККМ=Строка(т[1]);
	товарыСтрока.ВремяПродажи=т[2];
	товарыСтрока.Ошибка="";
	товарыСтрока.НомерЧека=т[3]; 		
	КонецЕсли;			
				
	товарыСтрока.Сумма=ЦенаТов;
			
		
		Иначе
	
		//Если Строка(ТипЗнч(текТов))<>"Справочник ссылка: Номенклатура" Тогда
			Сообщить("Поиск по строке вернул неопределенные результаты: "+ т[1]+" ," +т[2]+" ," +т[3]);	
			          Состояние("Поиск по строке вернул неопределенные результаты: "+ т[1]+" ," +т[2]);
			текТов=Справочники.Номенклатура.НайтиПоКоду("00000002");
		товарыСтрока.Номенклатура=текТов;
	  	товарыСтрока.ЕдиницаИзмерения=текТов.ЕдиницаХраненияОстатков;
	товарыСтрока.Количество=1;
	товарыСтрока.Коэффициент=1;
	товарыСтрока.ХарактеристикаНоменклатуры=ХарактеристикаНоменклатурыТов;
	ЦенаТов=	Ценообразование.ПолучитьЦенуНоменклатуры(текТов, ХарактеристикаНоменклатурыТов, ПолеВводаСклад.ТипЦенРозничнойТорговли);
	товарыСтрока.Цена= "";
	Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("КодуККМ", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ВремяПродажи", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("НомерЧека", МетаданныеДокумента, ИмяТабличнойЧасти)
				И ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("Ошибка", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
				 				
			товарыСтрока.КодуККМ=Строка(т[1]);
			товарыСтрока.ВремяПродажи=т[2];
			товарыСтрока.Ошибка="ошибка";
			товарыСтрока.НомерЧека=т[3];
	КонецЕсли; 	
	товарыСтрока.Сумма="";	
			КонецЕсли; 
	
КонецПроцедуры


Показать
Прикрепленные файлы:
датаколлектор_снятиеОтчетов.epf
36. PovAndy 23.12.13 12:47 Сейчас в теме
Меня интересует, будет ли работать обработка с 1С 8.2 Розница 2.0?

Стандартная АТОЛ-овская не работает на Розница 2.0!

Меня интересует инвентаризация с помощью ТСД!
41. Bublik2011 9 08.01.14 18:46 Сейчас в теме
(36) PovAndy, будет работать везде.

ВСЕ ГОРАЗДО ПРОЩЕ, РАБОТАЕТ ЛЕГКО.

Проблема: пришел к выводу, что неконтролируемый скан (какой ШК прочитал?) очень портит ревизию. Для ревизии хорош аппарат с дисплеем.

А Opticon хорош для исследований, среза товаров, регистрации продаж. То есть там, где можно исправить ошибку или ошибка мало значима для бизнес-процессов.
37. zwim 30.12.13 20:51 Сейчас в теме
Может я тороплюсь.Но никак не дождусь ответа на вопрос:никак не могу разобраться с подключением OPN-2001, даже после загрузки вышеуказанного файла.
40. Bublik2011 9 08.01.14 18:42 Сейчас в теме
(37) zwim, Вы правы. НАДО ЭТУ ахинею переписать в понятный вид, составить понятную инструкцию. Может, скооперируемся?))) Вышлю Вам обработку, переписанную под ТИС, проверенную, а Вы zwim , напишете инструкцию и сделаете скриншоты?

КАК УСТАНОВИТЬ ДРАЙВЕР

скачать по ссылке http://old.opticon.com/uploads/Software/USB/Drivers/Installer.exe или выбрать продукт из Opticon Software Download и скачать необходимое

ПРОЧИТАТЬ ДАННЫЕ В ФАЙЛ

Запустить файл EGFS0080.exe и нажать СТАРТ
(это прога в аттаче или на Opticon Software Download)


ЗАГРУЗИТЬ ДАННЫЕ

Запустить обработку, выбрать скачанный файл и нажать ВЫПОЛНИТЬ
Прикрепленные файлы:
DataDownloader.zip
ВнешняяОбработка1.epf
grfcrgy3.ert
44. PovAndy 18.01.14 13:23 Сейчас в теме
(40) Всё разобрался, кроме одного! Не могу запустить ни одну обработку под 1С 8.2 Розница 2.0, на всех выдаёт ошибку "Возможно, обработка (отчет) устарела или не является дополнительной:Метод объекта не обнаружен (СведенияОВнешнейОбработке)"
Это после конвертации, до нужной версии.

Может кто-нибудь помочь?
45. Bublik2011 9 18.01.14 15:56 Сейчас в теме
(44) PovAndy, цитирую сообщение про ошибку Возможно, обработка устарела или не является дополнительной и прихожу к выводу, что обработку нужно создать экспортную функцию СведенияОВнешнейОбработке. Можно наверное, пустую.
Функция СведенияОВнешнейОбработке() Экспорт

КонецФункции



Но мне хотелось с максимальной пользой учесть типовые механизмы 1С применимые для датаколлектора. Придется, в частности, описать в модуле объекта вашей обработки функцию. Спасибо за предложение, PovAndy .



42. Bublik2011 9 08.01.14 18:59 Сейчас в теме
(37) zwim, Опять аттач не виден, на старой версии Инфостарта возможно увидеть файлы, прикрепленные к сообщениям.

http://old.infostart.ru/public/83880/
38. zwim 30.12.13 21:02 Сейчас в теме
Почему то не нашел в нем обработки обслуживания ert.У меня 1С Предприятие 7.7 Торговля+Склад.Очень надо с помощью OPN2001 сбрасывать информацию о проданных товарах, собранную датаколлектором,в Торговлю+Склад.Неужели единственный выход обращаться к alexsandrguriev?
39. Bublik2011 9 08.01.14 18:28 Сейчас в теме
(38) zwim, Единственная проблема - скачать драйвер по ссылке.

КАК применять на практике

1) Шнур подключается к порту USB
2) Скачивается в файлик
3) Файлик обрабатывается и разносится по документам

ЧТО из себя представляют данные

Данные из Opticon, файлик вида 0000000000592301 01_10_13 17_36_05.csv
0000000000592301,4101326910014, 2:26:31 PM 12/28/12


0000000000592301,2000037910011, 3:11:46 PM 12/28/12



Например, данные из ККМ Штрих-М , файлик вида pos.rep
17152;29.08.2012;09:15:58;11;1;4596;3;10003411;2;800.00;1.000;800.00;
17153;29.08.2012;09:15:58;40;1;4596;3;;0;0.00;1.000;800.00;
17154;29.08.2012;09:15:59;55;1;4596;3;;0;0.00;0.000;800.00;


17176;29.08.2012;11:49:58;11;1;4601;3;10003801;2;400.00;1.000;400.00;
17177;29.08.2012;11:49:58;24;1;4601;3;6930232200081;2;0.00;1.000;0.00;
17178;29.08.2012;11:49:59;40;1;4601;3;;0;0.00;1.000;400.00;
17179;29.08.2012;11:49:59;55;1;4601;3;;0;0.00;0.000;400.00;





1)Вам необходимо придти к выводу, что штрих накопитель может применять ту-же обработку из TradeWare , что и ККМ Штрих-М

2)Формат данных в OPN гораздо проще. Плюс: миниум заморочек. Минус: для аналитики мало данных, только Штрихкод и дата-время.


По сути, обработка для OPN - парсер текстового файла.
а) прочитать строку, распарсить CSV to Massive или ТаблицуЗначений

б) метод 1: ТЗ в документ
метод 2: строку в документ (нет документа на дату-время-СОЗДАТЬ, есть документ-ДОБАВИТЬ)

Я прикреплял файл - обработку. После смена дизайна аттачи из этой ветки потерялись. Пишите в личку, вышлю. Неохота грязный-коденный файл выкладывать))


43. zwim 14.01.14 23:03 Сейчас в теме
Начинает потихоньку проясняться.Думаю, что скоро всё наладится.Спасибо!
46. err5 06.10.14 15:23 Сейчас в теме
Bublik2011, добрый день.
Очень хочется с Вами связаться по поводу этого датаколлектора.
Есть несколько вопросов от чайника.
Моя почта forjobmgn собака yandex.ru .
Уделите, пожалуйста, немного времени.
Спасибо!
47. Bublik2011 9 10.10.14 10:02 Сейчас в теме
Очень хочется с Вами связаться по поводу этого датаколлектора.


Этот датаколлектор не монтируется к OS Android. Недорогой датаколлектор хотел подключать к планшету или к телефону на WinMobile или Android. Применяется только с Windows..

У Вас есть идеи? Пишите в личку. Спасибо.
48. err5 10.10.14 12:25 Сейчас в теме
(47) я не могу написать Вам в личку на этом сайте, просят абонемент или какие-то $m, которых нет, поэтому написала свою почту.
В любом случае спасибо, что откликнулись.
Напишу тогда здесь.
Я живу в маленьком городе, где о таких вещах, как этот датаколлектор не знают, и спросить о его функционале не у кого, продавцы этого устройства, тоже ничего не объяснят, поэтому обращаюсь к Вам.
Мне для работы необходим сборщик штрих-кодов. Крупные магазины используют дорогущие ТСД, которые мне не подходят из-за цены, хочется получить какое-то недорогое устройство, которое даст возможность быстрее делать инвентаризацию не только единственным ручным сканером. В среднем в наличии имеется около 10 000 единиц, с которых необходимо считать штрих-код. Мы работаем в 1с торговля и склад 8.1 в своей конфигурации. При проведении инвентаризации, в форму документа можно загрузить штрих-коды из ТСД. Формат документа для загрузки должен быть в форме текстового документа с расширением txt.
Скажите, пожалуйста, этот сборщик даст возможность выгрузить собранные ШК в формате txt?
Спасибо большое за ответ!
49. Bublik2011 9 10.10.14 14:50 Сейчас в теме
(48) err5, он даст выгрузить данные. Файлик с даными парсится и заносится в 1с автоматически. Програмка для Оптикона в аттаче (при условии, что драйвера на него установлены)



дешевле чем связка "касса Штрих-М и ручной сканер + база 1с" 15тыс+1тыс+XX тыс.руб. не найти

Рекомендую , мне понравилось решение от фирмы, в которой видел листовку. БД+сканер+монитор=50тыс.

О чем хотел предупредить, err5 ? Этот датаколлектор - лишь так, насканировать без права на ошибку. Ведь индикатора нет, разумеется, на котором отображаеся, успешный скан или какой ценник просканирован. Согласитесь, у 10тыс.товаров 12тыс.ценников и ШК, верно? Поэтому базовое чего-то - это уже должно быть.

А датаколлектор и прочее - лишь для потехи оптимизации инвентаризации, например
Если ЭтотОбъект.Озвучивать Тогда
	СтрокаСумма = ?(ЗначениеЗаполнено(ЦенаТов), ЦенаТов, "зеро") ;
	ЗапуститьПриложение(КаталогПрограммы()+"Govorilka_cp.exe -E ""Digalo Russian Nicolai"" -p"+ЭтотОбъект.Тон+" -s"+ЭтотОбъект.Скорость+" -d ""c:\number.dic"" "+Формат((СтрокаСумма), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));	
КонецЕсли;


Еще есть вопросы, err5?
Прикрепленные файлы:
EGFS0080.exe
50. err5 10.10.14 16:41 Сейчас в теме
(49) спасибо Вам большое за ответ!
Но Вы мне льстите, я не программист и половину из написанного Вами не поняла, если есть возможность, пишите, пожалуйста, более понятными для обывателя словами.
Отвечаю на вопрос заданный в личке, потому что также не имею доступа для ответа. Сборщик ШК нужен для работы в теплом магазине + небольшой склад в этом же магазине, общая площадь около 60 м2, но имеется сложная планировка. Вы, наверное, хотите предложить в замен беспроводной сканер? Или видела у соседей проводной, но на очень длинном проводе специально для инвентаризаций.
Наше рабочее место - это ПК+1С+ФР+ручной проводной сканер самый простенький CIPHER.
При инвентаризациях с ручным проводным сканером необходима помощь еще одного человека, а лучше двух, для того, чтобы снимать вещи с настенного и напольного оборудования и подносить к рабочему месту, если на инв-ии работаешь один, то время проведения существенно увеличивается.
Но с ручным сканером есть проблема: при сканировании штрих-кодов приходится постоянно наблюдать за монитором ПК, т.к. бывают ситуации, когда окно документа "инв-я" в 1с самостоятельно перестает быть активным и пока по этому окну курсором не ткнешь (не могу сказать из-за чего и наш программист тоже этого не знает, мб Вы с этим сталкивались), сканируемый товар будет сканироваться сканером, но не попадать в этот документ, а сканер издает звук о том, что сканирование произошло. Это тоже ужасно тормозит процесс. И потом что-то приходится пересчитывать вручную.
В нашей базе 1с на данный момент более 35000 ШК.
Перед началом сбора ШК этим датаколлектором, мне необходимо будет загрузить в него имеющиеся в базе ШК или можно будет достать из коробочки и сразу же начать сбор?
У 10 000 товаров 10 000 штрих-кодов.
Извините за эти глупые вопросы, но никогда не имела возможности поработать с ТСД или сборщиками.
51. Bublik2011 9 10.10.14 23:33 Сейчас в теме

Да, очень длинный шнур. Но я почему-то куплю ТСД с дисплеем, решит много проблем, HR, например. Написал в личку.


52. serg1983 64 30.10.14 15:31 Сейчас в теме
У вас есть обработка для 8.3
53. Bublik2011 9 02.11.14 23:34 Сейчас в теме
(52) serg1983, откройте в конфигураторе обработку для 8.2 . Возможно в посте чуть выше - (45) есть ответ на какую-то непредвиденную проблему.

Если честно - задача статьи счастливым владельцам узнать про недостатки этого датаколлектора, найти драйвера и программку, которой текстовый файлик с на сосканированными ШК "сохраняется на диск". А далее этот файл обрабатывается ГДЕ угодно, даже в 8.4 методом "чтение файла"

Текст = Новый ЧтениеТекста(НазваниеФайла, КодировкаТекста.ANSI);
СтрокаТекста="";
Пока СтрокаТекста<>Неопределено Цикл
	 СтрокаТекста = Текст.ПрочитатьСтроку();
КонецЦикла;


А вот СтрокаТекста обрабатывается - ищется ШК, определяется номенклатура и заносится в документ.

serg1983, вы пробовали открыть в 8.3, что "не работает" ?
Оставьте свое сообщение