Расширение "Интерфейс Плюс"

Отраслевые решения - Торговля

Розница торговля расширение 54ФЗ поиск товаров кнопочный подбор

25
Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

 Данное расширение представлено в двух вариантах:

 
 1С:Розница 2.2

 Текущая версия 1.0.8

Что добавлено в расширение

 
 Расширенный список номенклатуры
 
 Поиск товара по штрихкоду по сайту Rate&Goods
 
 Редактирование цен в карточке номенклатуры
 
 Предпросмотр чека (РМК не поддерживается)
 
 Кнопки проведения и пометки на удаления в форме связанных документов
 
 Кнопочный подбор в РМК

Расширение разработано в Рознице версии 2.2.10.19 и протестировано на платформе 8.3.12.1714. Код полностью открыт.

Внимание! В силу ограничений расширения не работают на базовых ПЛАТФОРМАХ 1С. То есть, если запустить базовую Розницу под платформой версии ПРОФ, то расширение подключить можно!

Работа продолжается, как всегда жду ваших отзывов и предложений!

 
 Исправления в версии 1.0.1
 
 Новое в версии 1.0.2
 
 Новое в версии 1.0.4
 
 Новое в версии 1.0.5
 
 Новое в версии 1.0.6
 
 Новое в версии 1.0.7
 
 Новое в версии 1.0.8

 

 1С:Управление торговлей 11

 

25

Скачать файлы

Наименование Файл Версия Размер
Расширение "Интерфейс Плюс": Управление торговлей 11
.cfe 337,82Kb
13.12.18
11
.cfe 1.0.1 337,82Kb 11 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. klaus38 22.09.18 10:31 Сейчас в теме
Доброго... Отличная работа! Сложно будет, адаптировать её для УТ 11.4 ?
5. RocKeR_13 484 22.09.18 15:36 Сейчас в теме
(1) Здравствуйте! Думаю, не очень сложно будет перенести, но сроки не готов назвать
2. mafey 1 22.09.18 14:00 Сейчас в теме
Спасибо за работу! Офигенную вещь придумал
3. coolseo 47 22.09.18 15:13 Сейчас в теме
Здравствуйте, просто абалденно.
Предлагаю запилить что-то типо этого в ваше расширение
4. RocKeR_13 484 22.09.18 15:35 Сейчас в теме
(3) здравствуйте! Все это в "Помощнике" либо есть, либо появится в готовящемся обновлении)
mishinas1987; +1 Ответить
6. coolseo 47 23.09.18 11:25 Сейчас в теме
Здравствуйте, в карточке номенклатуры при установке цены была ошибка в коде (лишний цикл) - цена не попадала в установку цен.

Было так:

&НаСервере
Процедура Пом_ПрименитьЦеныНаСервере()
	
	УстановкаЦен = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
	УстановкаЦен.Дата = ТекущаяДата();
	Пом_Временная.Очистить();
	Дерево = РеквизитФормыВЗначение("Пом_Цены");
	Для Каждого Строка Из Дерево.Строки Цикл
		Для Каждого ТекущиеДанные Из Строка.Строки Цикл
			Если ТекущиеДанные.НоваяЦена > 0 Тогда
				ЗаполнитьЗначенияСвойств(Пом_Временная.Добавить(), ТекущиеДанные);
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
Показать




Стало так:
&НаСервере
Процедура Пом_ПрименитьЦеныНаСервере()
	
	УстановкаЦен = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
	УстановкаЦен.Дата = ТекущаяДата();
	Пом_Временная.Очистить();
	Дерево = РеквизитФормыВЗначение("Пом_Цены");
	Для Каждого ТекущиеДанные Из Дерево.Строки Цикл
			Если ТекущиеДанные.НоваяЦена > 0 Тогда
				ЗаполнитьЗначенияСвойств(Пом_Временная.Добавить(), ТекущиеДанные);
			КонецЕсли;
	КонецЦикла;
Показать
7. RocKeR_13 484 23.09.18 12:18 Сейчас в теме
(6) здравствуйте! Спасибо, здесь пропустил случай номенклатуры без характеристик
8. coolseo 47 23.09.18 12:40 Сейчас в теме
(7)Ждем, обновленную версию.
Продолжу тесты...
10. RocKeR_13 484 24.09.18 09:15 Сейчас в теме
9. user967468 23.09.18 20:48 Сейчас в теме
Присоединяюсь к адаптации под УТ 11.4, Очень удобно сделано!
11. RocKeR_13 484 24.09.18 09:16 Сейчас в теме
(9) Здравствуйте! Думаю, начну работу по адаптации к УТ в следующий понедельник, спасибо за отзыв!
12. mishinas1987 13 01.10.18 11:15 Сейчас в теме
Каким способом можно будет получать обновления после скачивания?
13. RocKeR_13 484 01.10.18 11:15 Сейчас в теме
(12) Здравствуйте! Пишите сюда или в личку, буду высылать
mishinas1987; +1 Ответить
14. mishinas1987 13 01.10.18 14:02 Сейчас в теме
Сделайте пожалуйста в номенклатуре, возможность отображения остатка товаров с нескольких складов (множественный выбор), у нас например отгрузка идет с 3х, заранее благодарен
15. RocKeR_13 484 01.10.18 14:28 Сейчас в теме
(14) Вы хотите для каждого склада отдельную колонку или достаточно будет суммы остатков по выбранным складам?
mishinas1987; +1 Ответить
16. mishinas1987 13 01.10.18 14:33 Сейчас в теме
17. RocKeR_13 484 01.10.18 14:42 Сейчас в теме
(16) посмотрю, что можно сделать
mishinas1987; +1 Ответить
24. mishinas1987 13 10.10.18 18:06 Сейчас в теме
(16)
Огромная благодарность Алексею за оперативную доработку программы, спасибо!
18. RocKeR_13 484 02.10.18 17:23 Сейчас в теме
На текущий момент приоритетные работы: адаптация расширения к УТ 11.4.
Что сделано на данный момент
1) Кнопки в форме связанных документов - ГОТОВО
2) Поиск товара по R&G с загрузкой фото, вводом цен и остатков - ГОТОВО
3) Изменение цен в карточке номенклатуры - В СТАДИИ ТЕСТИРОВАНИЯ/ОТЛАДКИ
mishinas1987; +1 Ответить
19. klaus38 02.10.18 21:19 Сейчас в теме
20. RocKeR_13 484 08.10.18 16:44 Сейчас в теме
21. klaus38 08.10.18 19:40 Сейчас в теме
22. user635667 43 10.10.18 04:08 Сейчас в теме
Публикация огонь! 5 звезд! Много хороших идей реализованно!
23. RocKeR_13 484 10.10.18 11:19 Сейчас в теме
25. user597811_loki111 10.10.18 20:02 Сейчас в теме
Здравствуйте а уже реализовано отображение остатков по двум и более складам ?
26. RocKeR_13 484 10.10.18 20:14 Сейчас в теме
(25) здравствуйте! Для Розницы да, завтра выложу
27. user597811_loki111 10.10.18 23:04 Сейчас в теме
а как можно будет получить обновление?
28. kokman 12.10.18 00:26 Сейчас в теме
Добрый день, а как обстоят дела с отображением остатков по характеристикам в разрезе складов?
29. coolseo 47 12.10.18 03:34 Сейчас в теме
Огромная просьба добавить в расширенную номенклатуру - возможность добавления списка цен закупочной и розничной.
Например есть 2 магазина у них разные цены, добавляет отображать какие нам цены нужны и на большом мониторе хорошо будет это видно!

Спасибо.
30. marko_polo 16.10.18 20:11 Сейчас в теме
подскажите почему ошибка выскакивает и что сделать чтобы ее победить. ??
Прикрепленные файлы:
31. RocKeR_13 484 16.10.18 20:18 Сейчас в теме
(30)хм, а у вас старая версия расширения? Я вроде переделывал запрос товара по штрихкоду с WinHTTPRequest на штатное HTTPСоединение
32. marko_polo 16.10.18 20:31 Сейчас в теме
хз, я только что с сайта скачал. :( а как новое получить?
33. RocKeR_13 484 16.10.18 20:34 Сейчас в теме
(32)постараюсь в течение часа проверить
34. marko_polo 16.10.18 21:06 Сейчас в теме
так же при установке расширения перестало работать "изменить выделенные."
выдает ошибку.
после удаления расширения заработало.
Прикрепленные файлы:
35. RocKeR_13 484 16.10.18 21:17 Сейчас в теме
(34) Для Розницы не переделал запрос товара по штрихкоду, сейчас подправим!
36. RocKeR_13 484 16.10.18 21:32 Сейчас в теме
(34) Отправил необходимую информацию в личку
37. coolseo 47 29.10.18 08:25 Сейчас в теме
(36) Здравствуйте столкнулся с этой же проблемой: изменить выделенные.
{ОбщийМодуль.ГрупповоеИзменениеОбъектовКлиент.Модуль(38)}: Поле объекта не обнаружено (Ссылка)
ПараметрыФормы.МассивОбъектов.Добавить(ТекущаяСтрока.Ссылка);

Прошу отправить исправленную версию.
Спасибо
38. user622591_serenia2110 27.11.18 17:00 Сейчас в теме
розница 2.2.10.19, выдает такую ошибку :РозницаПлюс (1.0.6): Критичная: Значение контролируемого свойства Тип у объекта Справочник.Номенклатура.Реквизит.КоличествоПериодовДействия не совпадает со значением в расширяемой конфигурации
39. RocKeR_13 484 27.11.18 17:03 Сейчас в теме
(38) здравствуйте! В ближайшее время буду обновлять расширение под 2.2.10
40. user622591_serenia2110 27.11.18 17:04 Сейчас в теме
примерно по дням сколько подскажите? , подождать или откатить назад нужно решить
41. RocKeR_13 484 27.11.18 17:05 Сейчас в теме
(40) ориентировочно завтра-послезавтра
42. mishinas1987 13 02.12.18 14:29 Сейчас в теме
43. mishinas1987 13 02.12.18 14:52 Сейчас в теме
А все, пока себе сделал, правда у меня версия 1.0.6 пишет, но подозреваю что это у меня 1.0.7 (так как вместе дорабатывали), как в дальнейшем получать обновления?
44. mafey 1 04.12.18 12:24 Сейчас в теме
А можно сделать, чтобы сохранялись настройки, а то получается каждый раз заходишь и настраиваешь расширенные список номенклатуры.
Вот еще идея добавить это расширение, чтоб оно работало в подборе номенклатуры к примеру в заказе покупателя
45. user622591_serenia2110 06.12.18 12:16 Сейчас в теме
Добрый день, выявили новую проблему , после добавления номенклатуры, если зайти в список номенклатуры , выбрать позицию, 1с повисает, потом минут через 15 вылетает
46. RocKeR_13 484 06.12.18 17:43 Сейчас в теме
(45) хм, проверю. Возможно зацикливание возникает на событии "ПриАктивизацииСтроки". Если подтвердится, буду переделывать вывод изображений в списке
47. user622591_serenia2110 06.12.18 17:46 Сейчас в теме
Возникает именно после создания номенклатуры, удаляешь расширение, заходишь все нормально, добавляешь заново, все работает, создаешь номенклатуру через запрос по штриху и потом повисает.
48. mafey 1 06.12.18 23:08 Сейчас в теме
А можно сделать, чтобы сохранялись настройки, а то получается каждый раз заходишь и настраиваешь расширенные список номенклатуры.
Вот еще идея добавить это расширение, чтоб оно работало в подборе номенклатуры к примеру в заказе покупателя
52. RocKeR_13 484 13.12.18 10:20 Сейчас в теме
(48) у вас, видимо, старая версия: в новых версиях сохраняются
49. user622591_serenia2110 08.12.18 18:05 Сейчас в теме
Добрый день, проблему с зависанием решили ?
50. RocKeR_13 484 08.12.18 18:32 Сейчас в теме
(49) Здравствуйте! Придется пока отменить вывод фото товара в списке. Как буду у компьютера внесу изменения
51. user622591_serenia2110 12.12.18 18:00 Сейчас в теме
Оставьте свое сообщение